cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jsidarta
Advocate I
Advocate I

[SOLVED] Custom Connector Definition - define a value to the HTTP Request Path Parameter

Hi,

 

I've created a custom connector to connect Power Automate (Flow) with NetSuite using OAuth2.0

According to NetSuite KB, to read, update, and delete a record, the record ID needs to be included in the URL.

 

For example:

- To get an employee record 107: 

 

 

GET https://demo123.suitetalk.api.netsuite.com/services/rest/record/v1/employee/107

 

 

- To update an employee record 107's firstname with "John": 

 

 

PATCH https://demo123.suitetalk.api.netsuite.com/services/rest/record/v1/employee/107
BODY { "firstname": "John" }

 

 

 

- To delete customer record 107:

 

 

DELETE https://demo123.suitetalk.api.netsuite.com/services/rest/record/v1/employee/107

 

 

 

As you can see, record 107 is included in the URL and not a POST/GET/PATCH parameter.
The question is, how can I create a custom connector definition that accepts the last path of the URL as the field/variable that can be entered during its usage as a parameter?
Flow01.png
Jsidarta_0-1602459181417.png

 

Thanks in advance

 
1 ACCEPTED SOLUTION

Accepted Solutions
Jsidarta
Advocate I
Advocate I

It turns out I need to put {variable} at the end of the link.

Example:

 

https://demo123.suitetalk.api.netsuite.com/services/rest/record/v1/employee/{employeeID}

 

Jsidarta_0-1602459251589.png

 

 

And the following is the result when you use it on Flow:

Jsidarta_1-1602109472823.png

 

View solution in original post

5 REPLIES 5
Jsidarta
Advocate I
Advocate I

It turns out I need to put {variable} at the end of the link.

Example:

 

https://demo123.suitetalk.api.netsuite.com/services/rest/record/v1/employee/{employeeID}

 

Jsidarta_0-1602459251589.png

 

 

And the following is the result when you use it on Flow:

Jsidarta_1-1602109472823.png

 

Anonymous
Not applicable

How did you configure your custom connector?

 

That's where I remain stuck.

 

Thanks in advance

Hi @Anonymous 

 

Where did you get stuck? 

I followed the following instructions: https://docs.microsoft.com/en-us/connectors/custom-connectors/define-blank

ReaganRogers
Frequent Visitor

I have created a custom connector for NetSuite using OAuth2. I am running into an issue where I can’t get the token to refresh did you run into that issue?

Hi @ReaganRogers what you have experienced is similar to this post. Let's discuss this issue in that thread.

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (1,452)