cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sperry1625
Solution Supplier
Solution Supplier

The Microsoft Dataverse Actions Missing

UPDATE:  This is not related to the environment.  I imported the flow into a prod environment and I have the same issue, the Dataverse actions are not available.  Under what conditions am I not permitted to use the Microsoft Dataverse connectors?

 

UPDATE: I have opened a ticket with Microsoft to find out what is causing this issue.  Will update everyone once I have a resolution.

 

I am trying to Update a record in dataverse but the only Dataverse connector I see is the Legacy Microsoft Dataverse connector.  Why?

 

I use true Development environments in my tenant for development, than deploy to Prod and Production.  I am developing a flow that needs to update Dataverse but I do not see the proper connector.  I see it in my other environments, but not Development environments. Is this by design or do I need to configure something?

 

Thanks.

Regards,

-S

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

1 ACCEPTED SOLUTION

Accepted Solutions
sperry1625
Solution Supplier
Solution Supplier

I have an update from Microsoft.

 

Short Answer: Rebuild the flow from scratch.

 

Longer answer: Microsoft stated that there was an issue with the flow that is causing that connector not to be available. They could not identify the exact issue, but the most likely fix was to recreate the flow from scratch. I am happy the flow was not very large. I recreated the flow and the problem went away.  Not an ideal resolution, but at least it was resolved.

Regards,

-S

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

View solution in original post

5 REPLIES 5
kapilsingla27
Frequent Visitor

Hello,

 

Have you got any update from Microsoft

sperry1625
Solution Supplier
Solution Supplier

I have an update from Microsoft.

 

Short Answer: Rebuild the flow from scratch.

 

Longer answer: Microsoft stated that there was an issue with the flow that is causing that connector not to be available. They could not identify the exact issue, but the most likely fix was to recreate the flow from scratch. I am happy the flow was not very large. I recreated the flow and the problem went away.  Not an ideal resolution, but at least it was resolved.

Regards,

-S

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Thanks for the answer but my flow is too large 😞 so rebuilding will be time consuming

Braaank
Frequent Visitor

In my case, it doesn't appear any connector regarding to Microsoft Dataverse from scratch nor in Connectors page.

 

Is there anything we are missing or Microsoft just remove this connector?

LenC
Resolver I
Resolver I

I am trying to copy and re-use an existing Flow, which used SharePoint, and now needs to use Dataverse.

 

I saved a copy of the original Flow. In this new version, the Dataverse connector and activities do not show up. Only the 'Dataverse (Legacy)' connector is available.

 

If I create a new Flow in the same environment, the Dataverse connector shows up just fine.

 

Is there some switch on the Flow that allows it to see the latest Dataverse connector?

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (4,077)