cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Natalie
Regular Visitor

Trigger not working: When Item is created

I've been using Microsoft Flow for some time, and have not have any issues until today.

 

I needed to create a new list and a flow that sends an email when a new item is created on the list.  I input everything as it should be into the flow, and the flow will not trigger.  I am getting the same error (see below).  I have event deleted the list, and rebuild the forms, AND deleted and recreated the flow several times.  Each time, I get the same error that the flow failed.  Why is this happening?  How can I fix this?  I am at a loss as to what I can do. 

 

Status Code: 400

 

Headers: {
  "Pragma": "no-cache",
  "x-ms-request-id": "ba6d0eb7-8774-40ff-ae9d-b739d759dac0",
  "Timing-Allow-Origin": "*",
  "Cache-Control": "no-cache",
  "Date": "Mon, 14 Aug 2017 16:35:16 GMT",
  "Set-Cookie": "ARRAffinity=6f8192aeb45a330cdb5f642ecc217dcd76db8eb70939a923860f458883127859;Path=/;HttpOnly;Domain=sharepointonlineconnectionprovider-westus.tip0-westus.p.azurewebsites.net",
  "Server": "Microsoft-IIS/8.0,Microsoft-HTTPAPI/2.0",
  "X-AspNet-Version": "4.0.30319",
  "X-Powered-By": "ASP.NET",
  "Content-Length": "371",
  "Content-Type": "application/json; charset=utf-8",
  "Expires": "-1"
}

 

Body:

{
  "status": 400,
  "message": "Specified argument was out of the range of valid values.\r\nParameter name: Folder\r\nclientRequestId: ba6d0eb7-8774-40ff-ae9d-b739d759dac0",
  "source": "https://twdc.sharepoint.com/sites/WDPR-DFAP/DFAPPhoto/_api/SP.APIHubConnector.GetNewListItems",
  "errors": [
    "-2146233086",
    "System.ArgumentOutOfRangeException"
  ]
}

 

 

2 REPLIES 2
v-yamao-msft
Community Support
Community Support

Hi Natalie,

 

How long has the SharePoint connection been created on your side? Please try to delete the old one and re-create the connection to see if it will work.


Error 400 means bad request. So please check the connection and make sure you have entered proper Site Address when you configure the flow.


To test this issue, I created a simple flow with the trigger “SharePoint – When an item is created”. The flow ran succeed when a new item is created.

3.PNG

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel!

 

Thanks for the response. 

 

I'm not quite sure what you mean by "SharePoint Connection."  The list is part of a SharePoint subsite.  The primary SharePoint site was created in March.  The subsite was created two weeks ago.  The list was created earlier in the week.  I deleted and recreated the subsite on Monday after the first few failed attempts.

 

I have removed the connection for this particular flow, and reestablished the connection when I created a new flow.  I am still getting the same errror and failed flow runs.

 

I have multple flows that run on multiple subsites, and I've only had an issue with this flow on this list on this subsite. I am an administrator on the SharePoint site, so it shouldn't be a access issue, right? 

 

Thoughts and additional assistance are greatly appreciated.

 

~Natalie

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Top Solution Authors
Top Kudoed Authors
Users online (4,033)