cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AntoinetteB
Frequent Visitor

500 Bad Gateway, 502 Access Denied error on Set Content Approval action. I fixed it, but a week later it started again.

All my flows are working in one library.  Last week I started adding flows for the first time to a different library.  I received the error below upon all Approve/Reject actions through Set Content Approval.  I had all my Etags in place correctly.  I looked at Library Permissions and noticed that I did not add the Owners permission group to this Library.  I fixed that, and then ran the flow successfully back on 9/1/2020.  Both Approve and Reject worked correctly.

 

Now today, 9/12/2020 I am having the same problem again, but I have not changed anything.  It reruns several times and then fails on the Set Content Approval action to Approve or Reject.  The Set content Approval actions to Draft and Publish are working fine.

 

The error and my flow are below:

ERROR:

{
  "error": {
    "code"502,
    "source""flow-apim-msmanaged-na-centralus-01.azure-apim.net",
    "clientRequestId""580083fc-b129-4bae-92d2-a610dbaf59a2",
    "message""BadGateway",
    "innerError": {
      "status"500,
      "message""Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))\r\nclientRequestId: 580083fc-b129-4bae-92d2-a610dbaf59a2\r\nserviceRequestId: 580083fc-b129-4bae-92d2-a610dbaf59a2"
    }
  }
 
MY FLOW:
 
 

screenshot1.GIFscreenshot2.GIFscreenshot3.GIF

2 REPLIES 2
CFernandes
Super User III
Super User III

@AntoinetteB If you resubmit the Power Automate(Flow) does it complete?

 

According to Microsoft article: If the error code 500 or 502 appears, the failure is temporary or transient. Click or tap Resubmit to try the flow again.

 

Referernce:

 

https://docs.microsoft.com/en-us/power-automate/fix-flow-failures#other-failures 

 

Also have a look at the thread: 

 

https://powerusers.microsoft.com/t5/Building-Flows/BadGateway-error-502-access-denied-in-approval-fl...

 

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

 

Thanks. Unfortunately in this case it did not solve my problem. Also, it stopped and started again 10 days later even though this time it continues. There are a number of people who have had this problem and solved it in some way by making some correction to their flow, but I have already tried all the suggestions I have been able to find through a Google search.

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (56,444)