cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Super User
Super User

502 Bad Gateway - Invalid text value - create Item when transferring SP directory to another list

when reading a sharepoint libarary directory and transfering it to another SP list (create item) i get errors below

 

 

{
  "error": {
    "code"502,
    "source""msmanaged-na.azure-apim.net",
    "clientRequestId""cade216c-a616-4739-81e5-e4376c08ac48",
    "message""BadGateway",
    "innerError": {
      "status"502,
      "message""Invalid text value.\n\nA text field contains invalid data. Please check the value and try again.\r\nclientRequestId: cade216c-a616-4739-81e5-e4376c08ac48\r\nserviceRequestId: ab15549e-a0f6-5000-2e0e-e5334ae616ae",
      "source""xxxx/_api/SP.APIHubConnector.CreateListItem",
      "errors": [
        "-2130575336",
        "Microsoft.SharePoint.SPException"
      ]
    }
  }
}

 

for files of the following path and name structure

 

File Name: xxx template FYnnnn_ xxxx xxxx Oct FF v 1.4 [xxx - shared] 01 12 2017.xlsb

File Path: Documents/06_xxxxxxxxxx/xxxxxxx xxxxxxxxx xx xxx xxxx/04. xxxxxx xxxxxxxxx/nnnn xxxxxx xx/xxx nnnn/[archive]/

 

 this is a surprise as the data are directly transfered from the sharepoint library list. Any idea why this is occuring and how to avoid? 

1 REPLY 1
Community Support Team
Community Support Team

Re: 502 Bad Gateway - Invalid text value - create Item when transferring SP directory to another lis

Hi @ErichH,

 

Could you please share a screenshot of your flow's configuration?

Do you want to transfer a SharePoint library directory to another SharePoint list?

Further, could you please show a bit more about the "Create item" action within your flow?

 

The error message told that there is a invalid value within your Text field. Please check if you have filled proper value within these fields of the "Create item" action of your flow. Please also check if the data type of dynamic content matches the data type of corresponding field within "Create item" action.

 

I could not reproduce your issue on my side currently, if you could provide more details about your scenario, we would provide a proper workaround for you.

 

Best regards,

Kris

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,118)