cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MarcelWortmann
New Member

A Event is created multiple times though it is only supposed to do it once

Im trying to create a automatic flow in Power Automate which creates a "15 minute buffer" after an event.
 

The calender i want the buffer in is the calender for a meeting room in my company, employees can create an Event in their calender and add the room as the location, the event is automatically added in the meeting room calender.

 

So far so good, the flow functions perfectly when i create the event directly inside the meeting room calender, however when i create it in another calender and add the meeting room calender ad the location, power Automate creates randomly 1-3 buffers. The flow is triggered when an event is added in the meeting room calender.

You can see in the picture what i mean.

 

 

2021-11-19 08_55_27-Schulungsraum_IT_NEUBAU_Max3Pers_Lüftungsintervall15min - Kalender - Schulungsra.jpg

 

Does anyone have an idea on how to fix this that so only 1 buffer is created over the cloud?

1 ACCEPTED SOLUTION

Accepted Solutions

Sorry I couldn't get you a useful answer. Not sure what else might be causing the duplication of the buffer.

View solution in original post

4 REPLIES 4
barret
Advocate IV
Advocate IV

Have you checked the run history of the flow to ensure that it isn't being triggered multiple times? It may be that your trigger isn't quite what it needs to be and is getting triggered multiple times, thus adding multiple buffers. If that looks fine, or if there isn't anything you can do to address the multiple triggers, you may need to come up with some additional logic to store the events to an Azure table or something and then check to see if that event has already been triggered before adding your buffer.

MarcelWortmann
New Member

The Flow is only triggered once. 

 

I will try adding some logic but i dont think thats really practical... 

I hoped there was a easy solution for this 🙂 

 

Best reguards 

Sorry I couldn't get you a useful answer. Not sure what else might be causing the duplication of the buffer.

View solution in original post

MarcelWortmann
New Member

No worries, noone can know everything 🙂 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (2,007)