cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
abbyamante
Frequent Visitor

Action 'Send_an_HTTP_request_to_SharePoint' flow " Input string was not in a correct format"

Hello, 

 

i build a flow to get the value of the changes on the sharepoint list columns. 

i am using the "Action 'Send_an_HTTP_request_to_SharePoint" to get the Value of the changes. I keep on getting this error "Input string was not in a correct format". 

 

can anyone please help me how to fix this error?

here is my flow and the error im getting:

 

abbyamante_0-1633097432825.png

 

error raw message

 


"statusCode": 400,
"headers": {
"Pragma": "no-cache",
"x-ms-request-id": "f2a9f39f-b084-1000-2106-018d52ff74ef",
"Strict-Transport-Security": "max-age=31536000; includeSubDomains",
"X-Content-Type-Options": "nosniff",
"X-Frame-Options": "DENY",
"Cache-Control": "no-store, no-cache",
"Set-Cookie": "ARRAffinity=661bb5a42aa72fa187081047289be23c4e8833591c3737a25cf4a4f79726a2fa;Path=/;HttpOnly;Secure;Domain=sharepointonline-eus2.azconn-eus2.p.azurewebsites.net,ARRAffinitySameSite=661bb5a42aa72fa187081047289be23c4e8833591c3737a25cf4a4f79726a2fa;Path=/;HttpOnly;SameSite=None;Secure;Domain=sharepointonline-eus2.azconn-eus2.p.azurewebsites.net",
"Timing-Allow-Origin": "*",
"x-ms-apihub-cached-response": "true",
"Date": "Mon, 27 Sep 2021 18:09:12 GMT",
"Content-Length": "457",
"Content-Type": "application/json",
"Expires": "-1"
},
"body": {
"status": 400,
"message": "Input string was not in a correct format.\r\nclientRequestId: 06834dc4-536c-46ad-a5cb-83f52cd42e53\r\nserviceRequestId: f2a9f39f-b084-1000-2106-018d52ff74ef",
"source": "https://pharmscript.sharepoint.com/sites/RevenueCycleOperations/_api/web/lists/getByTitle('Facility%...)",
"errors": [
"-1",
"Microsoft.SharePoint.Client.InvalidClientQueryException"
]
}
}

 

here is my current flow set up:

 

abbyamante_1-1633097554467.png 

abbyamante_2-1633097575555.png

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Expiscornovus
Super User
Super User

Hi @abbyamante,

 

Sorry, I forgot to look at the screenshot. 

 

With your current setup it would be the SinceVersionId field instead of the SinceVersionLabel field.

 

_api/web/lists/getbytitle('Facility%20Billing%20Allocation')/Items(@{triggerOutputs()?['body/ID']})/Versions(@{outputs('Get_changes_for_an_item_or_a_file_(properties_only)')?['body/SinceVersionId']})

 

View solution in original post

Expiscornovus
Super User
Super User

Hi @abbyamante,

 

I don't know why some don't show up, to be honest :). But you can still retrieve that field though.

 

You should be able to directly copy paste my last code snippet in the Uri field. Can you try that?

View solution in original post

5 REPLIES 5
Expiscornovus
Super User
Super User

Hi @abbyamante,

 

It looks like you are inputting 1.0 as the version value. However, that is the string value of the version. Microsoft expects a number. 1.0 corresponds with 512.

 

Try this URI instead

 

 

_api/web/lists/getByTitle('Facility%20Billing%20Allocation')/items(2951)/versions(512)

 

 

 

Expiscornovus
Super User
Super User

Hi @abbyamante,

 

Sorry, I forgot to look at the screenshot. 

 

With your current setup it would be the SinceVersionId field instead of the SinceVersionLabel field.

 

_api/web/lists/getbytitle('Facility%20Billing%20Allocation')/Items(@{triggerOutputs()?['body/ID']})/Versions(@{outputs('Get_changes_for_an_item_or_a_file_(properties_only)')?['body/SinceVersionId']})

 

View solution in original post

@Expiscornovus 

thank you for looking into this. when i try to change to what you mentioned above, im only getting the since version number on the dynamic content. 

 

abbyamante_0-1633113251826.png

 

do you know what would be the reason why i only have one option under the dynamic content?

Expiscornovus
Super User
Super User

Hi @abbyamante,

 

I don't know why some don't show up, to be honest :). But you can still retrieve that field though.

 

You should be able to directly copy paste my last code snippet in the Uri field. Can you try that?

View solution in original post

abbyamante
Frequent Visitor

@Expiscornovus  Youre Awesome!! it Works! thank you!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,063)