cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
askpatrickw
Frequent Visitor

Add Member to Team failing with Forbidden, but it actually actually succeeds

I have a flow which has worked for months, and just recently the Add Member to Team step is failing with Forbidden.

But the user is actually added to the team, so I'm very confused. The flow then fails and subsequent steps don't run.


Any suggestions?

 

{
"error": {
"code": "Forbidden",
"message": "You do not have permission to perform this operation.",
"innerError": {
"message": "You do not have permission to perform this operation.",
"code": "AccessDenied",
"innerError": {},
"date": "2022-09-02T19:31:19",
"request-id": "14c3ba78-700a-43e4-b5e0-a9f1a42d82e1",
"client-request-id": "14c3ba78-700a-43e4-b5e0-a9f1a42d82e1"
}
}
}
1 ACCEPTED SOLUTION

Accepted Solutions
askpatrickw
Frequent Visitor

We found a workaround... I put a 10 minute delay before the step to add to a Teams Group. Not ideal especially since it worked for months, but its OK for now.

View solution in original post

9 REPLIES 9
fchopo
Super User
Super User

Hi @askpatrickw 

Could you try to use another connection to Teams or remove it and add a new one?

Hope it helps!

Ferran

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

No this did not work.

 

I went to the connection, selected Switch Account, use my account again and it still failed the same way.

 

 

acoimbra
New Member

I have the same problem and this script is important for me.

I have a support call with @v-nathantr next week for this. I'll post back any outcomes.

Robin1988
Helper IV
Helper IV

@askpatrickw same here, any update on this?

askpatrickw
Frequent Visitor

No fix yet @Robin1988 ... But they're working on it.
NOTE: Removing and re-adding the connection did not fix this.

askpatrickw
Frequent Visitor

We found a workaround... I put a 10 minute delay before the step to add to a Teams Group. Not ideal especially since it worked for months, but its OK for now.

Just want to thank you for this solution. I gave up about a month ago on this, as I couldn't get it to work!


Dropped it to 5 minutes and it seemed to work as expected. Thanks again. 

 

acoimbra
New Member

I managed to get a workaround this without using delay by using azure adding user to group.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (2,709)