cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Add User to team using Power Automate

Hello All,

I have created a power automate to add user to team but getting below error.

 

{"<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
<title>404 - File or directory not found.</title>
<style type="text/css">
<!--
body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
fieldset{padding:0 15px 10px 15px;}
h1{font-size:2.4em;margin:0;color:#FFF;}
h2{font-size:1.7em;margin:0;color:#CC0000;}
h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}
#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
background-color:#555555;}
#content{margin:0 0 0 2%;position:relative;}
.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}
-->
</style>
</head>
<body>
<div id="header"><h1>Server Error</h1></div>
<div id="content">
<div class="content-container"><fieldset>
<h2>404 - File or directory not found.</h2>
<h3>The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.</h3>
</fieldset></div>
</div>
</body>
</html>"}

 

Does anybody have any Idea what I can do to fix this?

6 REPLIES 6
Super User III
Super User III

@dharam31 

Can you post a screen shot of your Flow?  That will be a big help to those trying to assist.  

Also, how are you obtaining the User ID that is required in the Add a member action?

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

@ScottShearer  Thank you for response.

Here are the screenshots. For time being I have added user id as hard coded value for testing purpose but still it is not working.

Scr1.PNGScr2.PNG

 

 
 

 

@dharam31 

Sorry - can't assist with this one.  I had assumed that you were adding a member to a Team in Teams rather than within Dynamics.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Hi @dharam31 ,

 

Taking a look at the documentation for the AddMembersTeam action, I verified that the entity reference is team as oposed to teams.

 

 

rimatos_0-1599053776729.png

 

Could you attempt to change the itemID field to reflect that?

 

Regards,

Ricardo

 

 

Hi @rimatos,

Thank you for response!

I tried by changing ItemID field to 'team' but still getting the same error.

 

Frequent Visitor

@dharam31 I know this is a few months late, but did you try using the unbound action AddMembersTeam rather than a Relate records step? I have used this successfully to add a user to a D365 team. 

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Microsoft Ignite

Microsoft Power Platform: 2021 Release Wave 1 Plan

Power Platform release plan for the 2021 release wave 1 describes all new features releasing from April through September 2021.

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (18,531)