cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DanielRK
Post Patron
Post Patron

Admin enabled multifactor authentication and now my flow broke

Hi,

 

I'm getting the following error in this step of my flow:

 

"Post your own adaptive card as the FlowBot to a user"- 

 
{
  "error": {
    "code""AuthorizationFailed",
    "message""A client certificate or authorization header was not provided."
  }
}

 

{
  "Pragma""no-cache",
  "x-ms-request-id""westeurope:33995e2d-545e-4ec6-af30-20b4f2cb6276",
  "x-ms-correlation-request-id""33995e2d-545e-4ec6-af30-20b4f2cb6276",
  "x-ms-flow-mobile-ios-version""1.3.0",
  "x-ms-flow-routing-request-id""WESTEUROPE:20210302T094803Z:33995e2d-545e-4ec6-af30-20b4f2cb6276",
  "Strict-Transport-Security""max-age=31536000; includeSubDomains",
  "X-Content-Type-Options""nosniff",
  "Timing-Allow-Origin""*",
  "x-ms-apihub-cached-response""false",
  "Cache-Control""no-cache",
  "Date""Tue, 02 Mar 2021 09:48:03 GMT",
  "Content-Length""140",
  "Content-Type""application/json",
  "Expires""-1"
}
Error code: 401
 
How do I fix this?
 
Thanks,
 
Daniel
1 ACCEPTED SOLUTION

Accepted Solutions
manuelstgomes
Super User II
Super User II

Hi @DanielRK 

 

This happens frequently. The connection was invalidated. You need to reconnect by creating a new connection and adding it to your Flow or fixing the current one. 

 

When you try to do the new connection you'll be asked for the MFA and this will solve the issue.

 

Can you please check if and let me know if you have any questions?

 

Cheers
Manuel

-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

2 REPLIES 2
manuelstgomes
Super User II
Super User II

Hi @DanielRK 

 

This happens frequently. The connection was invalidated. You need to reconnect by creating a new connection and adding it to your Flow or fixing the current one. 

 

When you try to do the new connection you'll be asked for the MFA and this will solve the issue.

 

Can you please check if and let me know if you have any questions?

 

Cheers
Manuel

-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

DanielRK
Post Patron
Post Patron

Thank you @manuelstgomes !

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Users online (42,738)