cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jtao
Helper I
Helper I

Approval escalation timeout value not save

I have approval escalation timeout set in "Start and wait for approval" and also configure run after timeout for escalation step.  First time run was successful as expected to escalate to 2nd level approval.  However, was unable to escalate for subsequent runs.  

Whenever I edit the flows and check the timeout value set but was blank. 

 

In order to get it working again, I had to re-key in the timeout value again every time.

Timeout set, escalation approval OKTimeout set, escalation approval OKSet timeout value. But value disappear when edit againSet timeout value. But value disappear when edit again

4 REPLIES 4
v-litu-msft
Community Support
Community Support

Hi @jtao,

 

I tried to reproduce your Flow to make a two-level approval and set a timeout duration, runs to check the timeout if disappear, but not find the same issue.

 

I assume the Flow is created from a template, right?

Have you tried to delete the Send an approval action then add a new one back?

If haven't, you could have a try.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Hi,

 

Thanks for testing my issue.  I have done some investigation today.  I have created and simplified the flows from scratch but still have the same issue.

 

My simplified version of Flows : 

- Wait for MS form submitted

- Get user/manager profiles

- Create item in Sharepoint list

- Start and wait for approval

- If more than 1 min, send email otherwise update sharepoint list

 

Once again, only worked for the first time.  However, I found something interesting.

1) If I tested again using  "resubmit", worked all the times.

2) If I edited the flow even though I did not make any change and tested again, it did not work.

 

I guessed once I went to edit mode, it wiped off the timeout value setting.  

 

Please note that I was using "Start and wait for approval" and I am located in Sydney, Australia.Simplified version of FlowsSimplified version of FlowsAlways Works if using resubmitAlways Works if using resubmitNot work if test again under edit modeNot work if test again under edit mode

I tried new version of Microsoft Edge today that has the same issue.  Both Microsoft Edge and Chrome has left the timeout value blank.  

I followed the video from John Levesque to create the same flows as him.  This time the timeout value can be saved.  

https://dynamics365society.uk/archives/microsoft-flow-approval-time-outs-escalations/

 

I tried to figure out what are the difference between my one and his one (My one cannot save the timeout value once going back to edit it).  I guessed that the only difference is my Approval step is inside "Apply For Each" loop.  I am quite sure it is a bug now !

Approval not inside "Apply for Each" loop can save timeout value.Approval not inside "Apply for Each" loop can save timeout value.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,051)