cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RoyDsouza
Helper I
Helper I

Automated Flow and SharePoint connections issue

Hello MPA community, 

 

I've come across a very odd instance in power automate. 

I am a owner of a Flow and have added a co-owner as well.

The goal of the flow is to Update a column (User or group column) and the trigger is when an item is created or modified in a SharePoint library list. Everything's works well when i add or modify an item. 

However, when the Co-owner tries to do it , the flows triggers/runs but does not update the column. 

We saw that when the SharePoint connection is changed at all the action steps in the flow (with the co-owners) only then patching occurs. 

 

I find it surprising and rather stunned that this is how it is..? I am missing something here?

Another concern: The SharePoint list has a different owners with edit access and i want the flow to run and update things when they do any changes as well. But they have to be a co-owner of the flow and connect their SharePoint with the flow every time? 

 

I hope i was able to put across my issue. 

If more info is required , I would be happy to share it. 

4 REPLIES 4
ScottShearer
Super User
Super User

It sounds as though the Flow is being initiated from Power Apps.  If that is the situation, switch to using a SharePoint When an item is created or modified trigger and I believe that will resolve the issue.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Hi @ScottShearer , 

I was hoping you'd reply. There was a  post on the similar lines few years ago where you had contributed and marked as solved - https://powerusers.microsoft.com/t5/General-Power-Automate/Need-to-use-another-User-s-connections-on...

 

However, my flow is not triggered/connected to power apps. Please have a look at it :

RoyDsouza_0-1630501303001.png

 

Some solutions I came across where to have a 'Service group' and use that account to create and the flows and apps. But it doesn't solve my underlying issue of SP list members/owners to use the flow.

 

 

@RoyDsouza 

In your post you mentioned that you added co-owners.  Are the users experiencing this issue making a copy of the Flow or executing your Flow?

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
RoyDsouza
Helper I
Helper I

@ScottShearer , Yes to a certain extent. I will explain it with 2 situations:

1) When their Sharepoint connection is not selected:  The co-owners are able to run the flow (without error) but the Update items (in the particular column) does not take place. 

2) When their Sharepoint connection is selected : Everything works fine. 

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (2,961)