cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Azure Creat User - Password Fail using @, Error Property passwordProfile.password is invalid

For some reason out of nowhere my MS Flow is no longer working.

 

Error: Action 'Create_user' failed

Error Details : Property passwordProfile.password is invalid.

 

Password using for test: Test@201906

This has been working for the last two months.

For some reason the '@' symbol is causing it to fail.

I can manually add a user and use this password without any issues.
MS Flow also doesn't fail if I replace the @ with anything else.  Unfortunately, I need to use the @.

Anyone know why Microsoft is no longer accepting @ for passwords in MS Flow?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate I
Advocate I

Re: Azure Creat User - Password Fail using @, Error Property passwordProfile.password is invalid

Ok, now this is odd.  For some reason after my 10th test it is now working.  #stress
Thank-you again for verifying on your side.

works1.jpg

 

View solution in original post

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Azure Creat User - Password Fail using @, Error Property passwordProfile.password is invalid

Hi @hlazier ,

 

Could you show me a screen shot of the flow run details?

 

I have just tried with Create user action with @ included in the password. However, it just runs successfully.

 

The issue you mentioned could not be reproduced.

 

Please check the run details as below:

1.PNG

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate I
Advocate I

Re: Azure Creat User - Password Fail using @, Error Property passwordProfile.password is invalid

Thank-you for testing this on your side.  I just tested this again this morning and received the same error message. 
Screenshots are below.  

Help1.jpg

 

 

Headers:

request-id

7f541003-XXXX

client-request-id

7f541003-XXXXX

x-ms-ags-diagnostic

{"ServerInfo":{"DataCenter":"North Central US","Slice":"SliceC","Ring":"1","ScaleUnit":"000","RoleInstance":"AGSFE_IN_26","ADSiteName":"NCU"}}

Duration

55.0925

Strict-Transport-Security

max-age=31536000

Timing-Allow-Origin

*

x-ms-apihub-cached-response

false

Cache-Control

private

Date

Thu, 06 Jun 2019 14:24:01 GMT

Content-Length

372

Content-Type

application/json

 

Body:

{

  "error": {

    "code": "Request_BadRequest",

    "message": "Property passwordProfile.password is invalid.",

    "innerError": {

      "request-id": "7f541003-XXXX",

      "date": "2019-06-06T14:24:01"

    },

    "details": [

      {

        "target": "passwordProfile.password",

        "code": "GenericError"

      }

    ]

  }

}

 

Highlighted
Advocate I
Advocate I

Re: Azure Creat User - Password Fail using @, Error Property passwordProfile.password is invalid

Ok, now this is odd.  For some reason after my 10th test it is now working.  #stress
Thank-you again for verifying on your side.

works1.jpg

 

View solution in original post

Helpful resources

Announcements
Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

Users online (6,218)