cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anon3218
Frequent Visitor

Bad Gateway while selecting folder inside library of Create and Rename Sharepoint connector

Hi,

 

I'm using flow to move files to a designated folder based on filename pattern. My flow is working but I went to change the folder this morning and I get a Bad Gateway.

Is there anyway to fix this as I don't get any error message other that bad gateway. 

See picture. Capture d’écran 2021-01-15 084159.png

8 REPLIES 8
Hardesh15
Super User
Super User

@Anon3218 

pls recreate your connection. it is temporary and fix automatically.

 

Thanks

Hardesh

Anon3218
Frequent Visitor

I tried to reset the sharepoint connection but it did not work.

 

I can navigate other library's folder with no problem. 

Anon3218_0-1610731469227.png

 

I'm the owner of this sharepoint and have full control over all those librairies.

Anon3218
Frequent Visitor

I tried recreating the flow and it also failed for the same reason. But I was able to get a better detailed error message:

 

when calling the ApiHubsRuntime API: 'Microsoft.Azure.ProcessSimple.Data.Entities.Exceptions.ProcessSimpleDataException: The ApiHubsRuntime API call failed with http status code 'BadGateway' and response content '{ "error": { "code": 502, "source": "msmanaged-na.azure-apim.net", "clientRequestId": "e8980b59-f3aa-4147-bb2f-76e3-e1b55b54", "message": "BadGateway", "innerError": { "status": 502, "message": "L’opération sollicitée est interdite car elle dépasse le seuil d’affichage des listes appliqué par l’administrateur.\r\nclientRequestId: e8980b59-f3aa-4147-bb2f-76e3-e1b55b54\r\nserviceRequestId: a4d0a29f-5030-b000-afb7-e4ae8cada38c", "source": "https://cascades.sharepoint.com/sites/SRV-042-CS_plus/_api/web/GetFolderByServerRelativePath(decodedUrl=@p)?$expand=Folders,Files&@p='%2fsites%2fSRV-042-CS_plus%2fRapports+CS+Confidentiels'", "errors": [ "-2147024860", "Microsoft.SharePoint.SPQueryThrottledException" ] } } }' at Microsoft.Azure.ProcessSimple.Data.DataProviders.AzureResourceManagerDataProvider.<>c__DisplayClass52_0`2.<<CallAzureResourceManager>b__0>d.MoveNext() in X:\bt\1188323\repo\src\processsimple\Roles\ProcessSimple.Data\DataProviders\Services\AzureResourceManagerDataProvider.cs:line 577 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at Microsoft.WindowsAzure.ResourceStack.Common.Algorithms.AsyncRetry.<Retry>d__3`1.MoveNext() in X:\bt\1182269\repo\src\common\core\algorithms\AsyncRetry.cs:line 0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at Microsoft.WindowsAzure.ResourceStack.Common.Algorithms.AsyncRetry.<Retry>d__3`1.MoveNext() in X:\bt\1182269\repo\src\common\core\algorithms\AsyncRetry.cs:line 171 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at Microsoft.Azure.ProcessSimple.Data.DataProviders.AzureResourceManagerDataProvider.<CallAzureResourceManager>d__52`2.MoveNext() in X:\bt\1188323\repo\src\processsimple\Roles\ProcessSimple.Data\DataProviders\Services\AzureResourceManagerDataProvider.cs:line 0'.

 


Any idea? The french error message reads : "The requested operation is prohibited because it exceeds the list display threshold applied by the administrator".

This library has ~5400 items. I even tried to modify the view to only show folder. No success.

I can browse other libraries easily. 

I decided to create a new library and start from scratch.

 

When library is empty with only 1 folder, the sharepoint flow connector is able to parse library folders without error.

When the library grows and a lot of files are added (~5k) it stops working. I don't know why. because I have other libraries with over 10k items and I don't have the Bad Gateway error.

 

Any idea? Would that be some kind of bug?

@Anon3218  your library is hitting defined threshold i.e 5k items. Please use filter query to filter out required data.

Thanks

Hardesh

This is where I don't get it.

 

I have another library which has over 10k items and a few folders (<10) And I don't hit that threshold when I use the same connector... Oh well... 

@Anon3218  please check your existing working flow and specially o data filter query.

Thanks

Hardesh

Anon3218
Frequent Visitor

There is no OData Filter.

 

The connector fails because it's not only parsing folder, it parse everything so it hits the 5k limit.

 

I believe this is a bug. 

 

Now I just came back to my flow and the connector disappeared...

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (2,210)