cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
frz
Level: Powered On

Basic Flow only working randomly

I have set up a simple Flow that posts a message in Teams and creates a task in Planner when an Email arrives with a certain subject.

Now the Flow works sometimes and succeeds without problems but most of the time Flow simply doesn't recognize the new email and never starts "the Flow".

 

Troubleshooting:

I can read my emails on outlook.office.com but not on outlook.com (no Microsoft account only office).

My Flow works randomly with the outlook.com and Office365 Outlook Connector, there seems to be no difference.

Since the Flow works as intended the problem seems to be with Office365 and/or our Exchange Server. (probably the communication between the two)

We acquired Office365 just recently and maybe there is something wrong with the synchronisation between our local Exchange and Office365 Outlook. What should i check?

 

Can somebody help me to identify the problem?

 

Best regards

2 ACCEPTED SOLUTIONS

Accepted Solutions
frz
Level: Powered On

Re: Basic Flow only working randomly

Hi Michael,

 

Thank you for your reply, if Office 365 Outlook and our local Exchange are indeed using somehow different mailboxes, that must be the root cause of my problem. But why is the Flow working sometimes?

 

I can access my emails on https://outlook.office.com/owa/?realm=XXX and with my desktop Outlook client connected to the local Exchange Server.

I only have one email and the mailboxes seem to be exactly the same so I was asuming it's indeed the same mailbox.

 

The Flow-Connector is set up with the Office365 Outlook account.

When I receive an email with the correct subject, the Flow only triggers 30% of the time. When it triggers it works perfectly.

 

So basically my Office 365 Outlook Account or the Flow-Connector only detects incoming emails as incoming emails 30% of the time. (Nonetheless they are always marked as new online)

 

I was hoping that someone ran into the same problem before, but I'm fairly sure it has something to do with the synchronisation between Exchange and Outlook365. I will look into that now, since the Flow must be set up the right way because it succeeds perfectly when it triggers.

 

frz
Level: Powered On

Re: Basic Flow only working randomly

I think I figured out the problem:

If you delete the incoming email from your inbox BEFORE it triggered the Flow, the Flow will never trigger.

I was able to reproduce this a couple of times now.

 

The last days, probably because of the migration, our mail system was pretty slow. Probably that influenced how long it would take the Flow to trigger and I simply wasn't patient enough and deleted the(presumably not working) test mails too fast.

 

Maybe that is obvious for most people but then the Flow Connector could be renamed in something like "If there is a new email in the inbox then" (instead of "when a new mail arrives")

 

Well, the problem seems to be solved.

 

 

4 REPLIES 4
Community Support Team
Community Support Team

Re: Basic Flow only working randomly

Hi @frz,

 

Microsoft Flow works with connections, each connection would have an Email Account.

And only Emails from that Email Account would be received in Microsoft Flow.

 

If here you mean all the Emails arrived in your Mailboxes (if contain multiple Email Account), then it is not possible for Microsoft Flow to receive all the Emails( triggers).

You need to create a flow for each mail account.

Further, based on what I know, local Exchange and the Office 365 Outlook are using different mailboxes, there should be two MailAccount for those two services.

Besides, local exchange is currenlty not supported under Microsoft Flow.

Manage connections in Microsoft Flow

An idea has been created for this:

connection to exchange

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
frz
Level: Powered On

Re: Basic Flow only working randomly

Hi Michael,

 

Thank you for your reply, if Office 365 Outlook and our local Exchange are indeed using somehow different mailboxes, that must be the root cause of my problem. But why is the Flow working sometimes?

 

I can access my emails on https://outlook.office.com/owa/?realm=XXX and with my desktop Outlook client connected to the local Exchange Server.

I only have one email and the mailboxes seem to be exactly the same so I was asuming it's indeed the same mailbox.

 

The Flow-Connector is set up with the Office365 Outlook account.

When I receive an email with the correct subject, the Flow only triggers 30% of the time. When it triggers it works perfectly.

 

So basically my Office 365 Outlook Account or the Flow-Connector only detects incoming emails as incoming emails 30% of the time. (Nonetheless they are always marked as new online)

 

I was hoping that someone ran into the same problem before, but I'm fairly sure it has something to do with the synchronisation between Exchange and Outlook365. I will look into that now, since the Flow must be set up the right way because it succeeds perfectly when it triggers.

 

frz
Level: Powered On

Re: Basic Flow only working randomly

I think I figured out the problem:

If you delete the incoming email from your inbox BEFORE it triggered the Flow, the Flow will never trigger.

I was able to reproduce this a couple of times now.

 

The last days, probably because of the migration, our mail system was pretty slow. Probably that influenced how long it would take the Flow to trigger and I simply wasn't patient enough and deleted the(presumably not working) test mails too fast.

 

Maybe that is obvious for most people but then the Flow Connector could be renamed in something like "If there is a new email in the inbox then" (instead of "when a new mail arrives")

 

Well, the problem seems to be solved.

 

 

Arno1975
Level: Powered On

Re: Basic Flow only working randomly

Same problem here, it was working fine, but the last weeks i am having this problem as well, just not running all the time

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 208 members 4,555 guests
Please welcome our newest community members: