cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ES_Bart
Regular Visitor

Calling Sharepoint API to update subsite library

Hi everyone

 

I have an issue with Sending HTTP request from Flow.

 

Situation as follows:

Site: company.sharepointonline.com

Subsite: company.sharepointonline.com/subsite

Document library: company.sharepointonline.com/subsite/documents

uri: _api/web/lists/GetbyTitle('documents')/items(123)/ValidateUpdateListItem()

 

When i try to send a call using site address company.sharepointonline.com, i have an error which is obvious, that "does not exist at site with URL",

But after many tries that ends with "Bad Gateway" i cannot figure out how to send a call to get to a sub site library item.

 

Untitled.png

1 REPLY 1
Expiscornovus
Super User
Super User

Hi @ES_Bart,

 

Can you try and use the subsite name at the start of the Uri field value?

 

Below is an example of that approach:

In this example I am using a variable for the subsite name.

 

@{variables('SubSiteName')}/_api/web/lists/GetbyTitle('Documents')/items(1)/ValidateUpdateListItem

 

subsitename_uri.png

 

Helpful resources

Announcements
Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (3,132)