cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
WaleedBinAfzal
Level: Powered On

Can anyone tell me why this flow fails to run properly when triggered multiple times?

Hi, 

I am trying to make a Microsoft Flow for Dynamics 365 CRM Sales assistant card, but it is giving error which I have no idea what I am doing wrong. Below are the details of the error that i am getting along with the screenshot of the assistant card.

 

Error Details: 

{
"code": 400,
"source": "ActionCardFlowService",
"message": "Empty \"Action input entity type\". Choose value from drop down and try again",
"innerError": " at Microsoft.Crm.Assistant.Odata.Helpers.ActionCardFlowResolver.<ExtractActionCardDetailsAsync>d__3.MoveNext()\r\n--- End of stack trace from previous location where exception was thrown ---\r\n at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)\r\n at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\r\n at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)\r\n at Microsoft.Crm.Assistant.Odata.Helpers.ActionCardFlowResolver.<ResolveEntity>d__0.MoveNext()\r\n--- End of stack trace from previous location where exception was thrown ---\r\n at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)\r\n at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\r\n at Microsoft.Crm.Assistant.AzureFunctions.ActionCardCreate.<CreateActionCard>d__1.MoveNext()\r\n--- End of stack trace from previous location where exception was thrown ---\r\n at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)\r\n at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\r\n at Microsoft.Crm.Assistant.AzureFunctions.ActionCardCreate.<Run>d__0.MoveNext()"
}
1.PNG
2 REPLIES 2
Dual Super User
Dual Super User

Re: Can anyone tell me why this flow fails to run properly when triggered multiple times?

Hi @WaleedBinAfzal 

 

Can you please share an expanded screenshot of the entire flow (barring any sensitive information). Please note that the error states "Choose value from drop down and try again" and  I am guessing that somewhere in a defined set of options a custom value has been entered and that is not getting recognised. Can you please check and confirm this?

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Seb_Dal
Level: Powered On

Re: Can anyone tell me why this flow fails to run properly when triggered multiple times?

"message""Empty \"Action input entity type\". Choose value from drop down and try again",

Capture.PNG

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Speakers, submit your sessions now! Call for speakers ends Feb. 10!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (2,303)