cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Sebastiaan1
Regular Visitor

Daily Recurrence flow

Hi all, (Hope I post this in the correct section).

 

I am fairly new to Power Automate/Flow and currently having a bit of an issue with a recurrence flow that I would like to create for a daily shift report. I originally had a flow running that when an item or file is modified an e-mail would be generated and distributed within the organisation, however after every update in the sharepoint page of a file/folder an e-mail would be generated. So I was thinking to change this to only once a day. But for some reason the recurrence seems not to be working. Would anyone be able to advise or has anyone another solution on how to prevent that an e-mail is generated with every update?

 

Thank you so much!

 

Best Regards,

Sebastiaan

 

Sebastiaan1_0-1606473691036.pngSebastiaan1_1-1606473751875.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Sebastiaan1,

 

Sorry my bad, I made a mistake in the steps. Step 4 should be:

 

4. Add the expression I shared earlier to the Filter Query field. You can directly paste this in the Filter query field. Without having to use the add an expression button.

 

Modified ge '@{formatDateTime(utcNow(), 'yyyy-MM-ddT00:00:00Z')}'

 

 

The end result should also contain the Modified ge part to make it work.

 

 

View solution in original post

7 REPLIES 7
Expiscornovus
Dual Super User
Dual Super User

Hi @Sebastiaan1,

 

I see you have two triggers in one flow. I would suggest you remove the when an item or a file is modified trigger action and add a different action for it instead.

 

You could for instance use the Get files (properties only) action and use the filter query field to only retrieve file ids which are last modified today. Below is an example of such a configuration. I am using the following expression: 

formatDateTime(utcNow(), 'yyyy-MM-ddT00:00:00Z')

 

getfilespropertiesonly.png

 

Hope this helps a bit?

Hi Thank you very much!

 

Just wondering how should I enter this? formatDateTime(utcNow(), 'yyyy-MM-ddT00:00:00Z')

Is that just the empty recurrence or do I add this in an other way? 

 

Expiscornovus
Dual Super User
Dual Super User

Hi @Sebastiaan1,

 

I don't think you need to change your schedule trigger action. I think you can just execute the following steps.

 

1. Remove the When an item or file is modified trigger action

2. Add a Get files (properties only) action

3. Configure it to use your existing list

4. Add the expression I shared earlier to the Filter Query field. You can add the expression in the filter query field via the add an expression button and copy pasting this expression:

4. Add the expression I shared earlier to the Filter Query field. You can directly paste this in the Filter query field. Without having to use the add an expression button.

 

Modified ge '@{formatDateTime(utcNow(), 'yyyy-MM-ddT00:00:00Z')}'

 

 

addanexpression.png

 

Hope this makes it a bit clearer what I was trying to propose. If you need any additional help just let us know.

 

Update: Changed my mistake in step 4.

Thank you! However I am getting the following error message: 

 

The expression "2020-11-29T00:00:00Z" is not valid. Creating query failed.
clientRequestId: c6b096eb-af31-46f2-9251-e0a468a0c108
serviceRequestId: c6b096eb-af31-46f2-9251-e0a468a0c108

 

Any idea what I do wrong?


Sebastiaan1
Regular Visitor

Sebastiaan1_3-1606683584466.png

 

Hi @Sebastiaan1,

 

Sorry my bad, I made a mistake in the steps. Step 4 should be:

 

4. Add the expression I shared earlier to the Filter Query field. You can directly paste this in the Filter query field. Without having to use the add an expression button.

 

Modified ge '@{formatDateTime(utcNow(), 'yyyy-MM-ddT00:00:00Z')}'

 

 

The end result should also contain the Modified ge part to make it work.

 

 

Sebastiaan1
Regular Visitor

Hi all,
The flow has been working smooth for a while until yesterday, for some reason the link to the file is not working correctly anymore, I haven't changed the flow.

 

As you can see suddenly the %20 disappeared between Shift and Reports.

 

New Situation:

 

Sebastiaan1_0-1611781912417.png

 

Old situation:

Sebastiaan1_1-1611782031538.png

 

Flow:

Sebastiaan1_2-1611782133322.png

 

Sebastiaan1_3-1611782203696.png

 

Anyone any idea on what it can be?

Thank you!

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (1,791)