cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper III
Helper III

Date format in Approval email

Hello,

 

I created a flow with a set of multi level approvers. The date/time stamp is added to the following approvers email but the formatting is off after my first approver. How can I get the date/time format to look as the first one?

 

Thank you in advance!

 

Approval date format.jpg

 

4 REPLIES 4
Microsoft
Microsoft

Hello,

Please try to use expression "formatDateTime" to format the datetime.

 

For more details:

https://docs.microsoft.com/en-us/azure/logic-apps/workflow-definition-language-functions-reference#f...

 

In this scenario, you may try to create a flow and configure the code to format the datetime using the following function:

formatDateTime(body('Start_an_approval')?['responseDate'],'MMMM dd,yyyy hh:mm tt')

tingtingluo_0-1613829708584.png

 

tingtingluo_0-1613829668661.png

 

If I have answered your question, please mark your post as Solved.

 

Thank you.

Thanks for your response @tingtingluo. This is all very new to me and I need a little bit more direction. 

 

The function/expression you provided, would I create a Compose action with this expression or do I use this in place of where the date should be in the approval email?

 

I have several approval emails throughout my workflow. 

approval date format.jpg

Microsoft
Microsoft

Hi @knandez05 

Thanks for the instant reply.

The Compose action is like a static variable. It can be placed anywhere within your flow, and its value can be accessed from anywhere within the flow. The value is persistent – once it is set it cannot be changed.

It's convenient to convert the format of several Date fields. To make the Compose card easier to find later, rename it by selecting the text Compose on the title bar of the card and entering a name that's easy to remember.

https://docs.microsoft.com/en-us/power-automate/data-operations#use-the-compose-action

https://www.powerautomatetraining.co.uk/post/the-compose-action

Best Regards,

Thank you  When I try to add to my flow, I get the following errors when saving.

 

The template validation failed: 'The action(s) 'Start_an_approval' referenced by 'inputs' in action 'Compose_4' are not defined in the template.'

 

Correct to include a valid reference to 'Start_an_approval' for the input parameter(s) of action 'Compose_4'.

 

compose flow error.jpg

Helpful resources

Announcements
New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (64,317)