cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
AdamRobC
Level: Power Up

Email not dropping into SharePoint folder

Hi,

 

I have a basic flow set up that should drop a .xlsx email attachment into a SharePoint folder. Existing flows I've set up using the template are working fine but for some reason although this flow runs successfully nothing is dropped into SharePoint.

 

Attaching some images of the flow checker below on a test run. As you can see it seems to not create any files but hasAttachment is returning True. Any ideas what could be going on?

 

Thanks,

Adam

 

Capture.PNG

Capture2.PNGCapture3.PNG

 

1 ACCEPTED SOLUTION

Accepted Solutions
AdamRobC
Level: Power Up

Re: Email not dropping into SharePoint folder

Ok I think I managed to get it working now - might have just been a testing bug

View solution in original post

7 REPLIES 7
Super User
Super User

Re: Email not dropping into SharePoint folder

@AdamRobC 

Can you post a screen shot of your Flow in Edit mode?

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
AdamRobC
Level: Power Up

Re: Email not dropping into SharePoint folder

Sure - it's almost as if it's not finding any attachments even though it registers them...

 

Capture.PNG

 

Capture2.PNG

Krishna92
Level 8

Re: Email not dropping into SharePoint folder

@AdamRobC 

The Has Attachment value depends on what you select in the action card. If you select YES for Has Attachment in the action card then it will return true, if you select no then it will return FALSE

 

As per the outputs that you have attached I see that there are no attachments attached in the email.

Could you please try adding up some data and test if it works.

 

 

AdamRobC
Level: Power Up

Re: Email not dropping into SharePoint folder

Hi @Krishna92 

 

This is a sample email in question - as you can see there definitely is an attachment.

 

Capture.PNG

Community Support Team
Community Support Team

Re: Email not dropping into SharePoint folder

Hi @AdamRobC ,

 

As @Krishna92  said, from your flow run history I see that there are no attachments attached in the email, please take a try to send an email with attachment again to see if your flow works.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

AdamRobC
Level: Power Up

Re: Email not dropping into SharePoint folder

Hi @v-alzhan-msft 

 

I sent a screenshot of the email with the attachment. See below for further evidence.

 

If it's not recognizing the attachment then that is the issue to solve.

 

Capture.PNGCapture2.PNG

 

Thanks,

Adam

AdamRobC
Level: Power Up

Re: Email not dropping into SharePoint folder

Ok I think I managed to get it working now - might have just been a testing bug

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,480)