cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
uiterlex
Advocate I
Advocate I

Error: 'GetFileItems' is missing required property 'body/value/0/RoutingTargetFolder'.

Anybody know how to solve this?

I have a Flow that is giving an error (?) and another one one the same Document Library not?

Action step: Sharepoint: Get_files_(properties_only)

uiterlex_0-1598906057420.png

 

 

Gives an error: 'GetFileItems' is missing required property 'body/value/0/RoutingTargetFolder'.

 

uiterlex_1-1598906057421.png

 

 

 

 

Another Fow is running well:

Action step: Sharepoint: When a file is created or modified (properties only)

uiterlex_2-1598906057422.png

 

Thank for helping me ... 👍

1 ACCEPTED SOLUTION

Accepted Solutions
Mira_Ghaly
Dual Super User II
Dual Super User II

@uiterlex 

Can you try on the Filter Query to Add ContentType ne 'Folder' to the ODATA filter.

This has been suggested by another similar issue.

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

View solution in original post

6 REPLIES 6
Mira_Ghaly
Dual Super User II
Dual Super User II

@uiterlex Have you selected the folder or added it manually? If manually try to select it from the folder selection. 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

@Mira_Ghaly  I have selected it, from the folder list (after selecting the folder icon)

Also tried to leave it out and tried to select a sub-folder ... both generating the same error.
but according the error it cannot find the 'target folder'

thanks for trying, Mira

Mira_Ghaly
Dual Super User II
Dual Super User II

@uiterlex 

In case you did not try it , try removing the Top Count and the Limit Columns by View

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

@Mira_Ghaly  ... yes, Mira, both tried out ... did not work out.

Note I have > 5K files in 'TekeningenPP/', thats why I tried with limitation(s)

Mira_Ghaly
Dual Super User II
Dual Super User II

@uiterlex 

Can you try on the Filter Query to Add ContentType ne 'Folder' to the ODATA filter.

This has been suggested by another similar issue.

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

View solution in original post

@Mira_Ghaly  👍😊   Yep, that's the solution to solve the error.
I have set the Top Count to 5000 (=max)

and set the Limit Columns by View to default

uiterlex_0-1598916601720.png

Thanks, Mira, for helping me finding the solution.

... and happy I have asked this in the community.

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (47,576)