cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kgregg
New Member

Export email step suddenly failing with error - bad gateway, mailbox move in progress

I have several flows built that look for new emails coming into an O365 shared inbox.  The first step is to export the email which had been running successfully for some time but starting today, all of the flows are erroring out with the following error.  Any ideas?

 

{
    "statusCode"502,
    "headers": {
        "Transfer-Encoding""chunked",
        "Retry-After""15",
        "Vary""Accept-Encoding",
        "Strict-Transport-Security""max-age=31536000",
        "request-id""de015b54-08b3-4ff7-9c41-3d29f9f52536",
        "client-request-id""de015b54-08b3-4ff7-9c41-3d29f9f52536",
        "x-ms-ags-diagnostic""{\"ServerInfo\":{\"DataCenter\":\"West US\",\"Slice\":\"E\",\"Ring\":\"5\",\"ScaleUnit\":\"002\",\"RoleInstance\":\"BY1PEPF00002EF9\"}}",
        "Timing-Allow-Origin""*",
        "x-ms-apihub-cached-response""true",
        "Cache-Control""private",
        "Date""Wed, 21 Apr 2021 13:27:10 GMT",
        "Content-Type""application/json",
        "Content-Length""436"
    },
    "body": {
        "error": {
            "code"503,
            "source""flow-apim-msmanaged-na-westus2-01.azure-apim.net",
            "clientRequestId""4858d938-011e-4b97-a025-d7fb94d1be35",
            "message""BadGateway",
            "innerError": {
                "error": {
                    "code""ErrorMailboxMoveInProgress",
                    "message""Mailbox move in progress. Try again later., The user and the mailbox are in different Active Directory sites."
                }
            }
        }
    }
}
22 REPLIES 22

This solution works for me...i added the shared mailbox address from which the email is fetched for exporting.

pauldj
Advocate II
Advocate II

I'm having the same issue as above, although i can see (from my flows) that this is only effecting flows where there are attachments. I re added the email address in all points of the flow - and for now it appears fixed - will monitor.

leedolby
Regular Visitor

Yup .. that fixed it for me too!

 

Thanks kierian!

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

Users online (1,570)