cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kgregg
New Member

Export email step suddenly failing with error - bad gateway, mailbox move in progress

I have several flows built that look for new emails coming into an O365 shared inbox.  The first step is to export the email which had been running successfully for some time but starting today, all of the flows are erroring out with the following error.  Any ideas?

 

{
    "statusCode"502,
    "headers": {
        "Transfer-Encoding""chunked",
        "Retry-After""15",
        "Vary""Accept-Encoding",
        "Strict-Transport-Security""max-age=31536000",
        "request-id""de015b54-08b3-4ff7-9c41-3d29f9f52536",
        "client-request-id""de015b54-08b3-4ff7-9c41-3d29f9f52536",
        "x-ms-ags-diagnostic""{\"ServerInfo\":{\"DataCenter\":\"West US\",\"Slice\":\"E\",\"Ring\":\"5\",\"ScaleUnit\":\"002\",\"RoleInstance\":\"BY1PEPF00002EF9\"}}",
        "Timing-Allow-Origin""*",
        "x-ms-apihub-cached-response""true",
        "Cache-Control""private",
        "Date""Wed, 21 Apr 2021 13:27:10 GMT",
        "Content-Type""application/json",
        "Content-Length""436"
    },
    "body": {
        "error": {
            "code"503,
            "source""flow-apim-msmanaged-na-westus2-01.azure-apim.net",
            "clientRequestId""4858d938-011e-4b97-a025-d7fb94d1be35",
            "message""BadGateway",
            "innerError": {
                "error": {
                    "code""ErrorMailboxMoveInProgress",
                    "message""Mailbox move in progress. Try again later., The user and the mailbox are in different Active Directory sites."
                }
            }
        }
    }
}
22 REPLIES 22

This solution works for me...i added the shared mailbox address from which the email is fetched for exporting.

pauldj
Advocate II
Advocate II

I'm having the same issue as above, although i can see (from my flows) that this is only effecting flows where there are attachments. I re added the email address in all points of the flow - and for now it appears fixed - will monitor.

leedolby
Regular Visitor

Yup .. that fixed it for me too!

 

Thanks kierian!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,753)