cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ls2346
Regular Visitor

Flow Approval Error

Everything was working fine a few days ago, but now I get an error code when my flow is waiting for an approval. 

Forbidden. The request failed. Error code: 'ApiManagementAccountNotAllowed'. Error Message: 'Call not allowed from api management account 'msmanaged-na'.'.

 

My current code is: 

{
"inputs": {
"host": {
"connection": {
"name": "@parameters('$connections')['shared_approvals']['connectionId']"
}
},
"body": {
"notificationUrl": "@{listCallbackUrl()}",
"title": "Title of  Request",
"assignedTo": "persons email",
"details": "The following is being requested by @{body('Get_response_details_2')?['r505642349a904d3facafa40a9ad69df4']} @{body('Get_response_details_2')?['r38ef4e5fa71a4f218e8cb25d32a8b582']}:\n@{body('Get_response_details_2')?['r90bd05d2db4d49dcaf22a70bdcabee45']} \nArea(s): @{body('Get_response_details_2')?['r6b4978acf7be41b9b09180a4e6c1b912']}\nDates: @{body('Get_response_details_2')?['r8fce35ea28fb44f9abccfed85e47091e']} to @{body('Get_response_details_2')?['rd0d36415144244efbf0704ec49a44437']}\nfor @{body('Get_response_details_2')?['r7be4853875054369b8eb544eeb685050']}\nStart time @{body('Get_response_details_2')?['r57a480a9444941e39036bb69461253ad']} End time @{body('Get_response_details_2')?['raa896adb35664dcd91ea1daf2c1d0386']}\nto provide service to @{body('Get_response_details_2')?['r39b9d1a0cd4b45459f58372f58c9534b']} \n@{body('Get_response_details_2')?['rca240a01bdda47929fd8ff43f5593f50']}\nIf you have questions please call the Help Desk...",
"requestor": "@body('Get_user_profile_(V2)')?['mail']",
"enableNotifications": true
},
"path": "/types/@{encodeURIComponent('Basic')}/$subscriptions",
"authentication": "@parameters('$authentication')"
},
"metadata": {
"flowSystemMetadata": {
"swaggerOperationId": "approvalSubscribeV2"
}
}
}

How do I fix this without having to redo eveything or braeking anthing else?

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-yamao-msft
Community Support
Community Support

Hi @Ls2346 ,

 

Could you share a screenshot on your flow?

 

I have made a simple flow with approval action Start and wait for an approval, however, the issue you mentioned could not be reproduced, it works successfully.

1.PNG

 

Please share more details on the flow to help reproduce this issue.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-yamao-msft
Community Support
Community Support

Hi @Ls2346 ,

 

Could you share a screenshot on your flow?

 

I have made a simple flow with approval action Start and wait for an approval, however, the issue you mentioned could not be reproduced, it works successfully.

1.PNG

 

Please share more details on the flow to help reproduce this issue.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

cjhealy
Advocate III
Advocate III

Just an FYI I received this same error on a Flow approval yesterday - everything seems to be working correctly today. 

Very odd

 

 

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (55,877)