cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Flow Bug: 'Get User Profile' fails when user's primary SMTP is different from UPN

'Get User Profile' action fails when user's primary SMTP address is different from UPN (i.e. EasyID in MSIT e.g. Firstname.Lastname@domain.com instead of alias@domain.com).

 

Error:

{
  "status": 404,
  "message": "No user found with the specified id.",
  "source": "office365usersconnectionprovider-centralus.tip0.p.azurewebsites.net"
}

 

FlowSMTPUPNBug.jpg

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Flow Bug: 'Get User Profile' fails when user's primary SMTP is different from UPN

Hi @NishantS,

 

I have reported this to the product team. I will get back once I got any further information.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Microsoft
Microsoft

Re: Flow Bug: 'Get User Profile' fails when user's primary SMTP is different from UPN

I am having the same issue. Is there an update or is there a workaround?

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (6,798)