cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
deeps2210
New Member

Flow Email activity fails

I have a flow with email activity.  The email is using Office 365 Outlook.

The email activity fails with below message

 

"Unable to process template language expressions in action 'Send_an_email' inputs at line '1' and column '1970': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_office365']['connectionId']' cannot be evaluated because property 'shared_office365' doesn't exist, available properties are 'shared_sharepointonline, shared_gmail'. Please see https://aka.ms/logicexpressions for usage details.'."

 

I have tried other email activities, like gmail, outlook etc.  All email activities fail with same message.  What is going on?flowemailfails.PNG

1 REPLY 1
AlanPs1
Resident Rockstar
Resident Rockstar

Hi @deeps2210 , thanks for your post in the Flow Community.

 

The issue you describe is more of a blip or a bug and I have seen it remedied in a few ways.

 

1) Export your Flow to zip and re-import to your dashboard

2) Recrete your connections to the connector

3) as your Flow is small, I'd say can it be rebuilt as new?

 

It is likely point 1, or 3 will definitely fix this and possibly, point 2 will also.

 

If you have found my post helpful, please mark thumbs up.

 

Any other questions, just ask.

 

Thanks, Alan

 


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (2,189)