cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flow Error: "ActionFailed. An action failed. No dependent actions succeeded."

A few of my flows simply would not keep working. They say "ActionFailed. An action failed. No dependent actions succeeded." for each Approval Condition and Apply to Each, and then on the subsequent Update Item. It's saying that the approvers (I have 2) have the files locked for shared use? But I don't know how that's possible. Any ideas?

 

I should mention that other flows of the exact same type have gone through fine; it's just some of them had to be resubmitted or failed altogether, and I don't know what makes some work and some fail. 

1 ACCEPTED SOLUTION

Accepted Solutions
v-yuazh-msft
Community Support
Community Support

Hi @Anonymous,

 

Could you please share a screenshot of the configuration of your flow?

Could you please share a screenshot of the flow run details when the flow run failed?

 

I afraid the action inside the branch of the Condition in your flow have run failed so the Condition would display the error that you mentioned.

 

Please share more details so we would try to provide a proper workaround for you.

 

Please take a try to delete the entire flow and started from scratch, and it immediately worked.  

 

Also please make sure all the connections are in good condition, navigate to the connections page to see if there are any related connections need to update the credentials.

 

Best regards,

Alice

View solution in original post

5 REPLIES 5
v-yuazh-msft
Community Support
Community Support

Hi @Anonymous,

 

Could you please share a screenshot of the configuration of your flow?

Could you please share a screenshot of the flow run details when the flow run failed?

 

I afraid the action inside the branch of the Condition in your flow have run failed so the Condition would display the error that you mentioned.

 

Please share more details so we would try to provide a proper workaround for you.

 

Please take a try to delete the entire flow and started from scratch, and it immediately worked.  

 

Also please make sure all the connections are in good condition, navigate to the connections page to see if there are any related connections need to update the credentials.

 

Best regards,

Alice

GabrielStJohn
Community Champion
Community Champion

Hey, @Anonymous!

 

Thank you for posting on the Flow Community Forum! It appears as though @v-yuazh-msft would like some more information in order to further assist you properly with your issue. Please share any additional information that was requested in order to decrease the amount of time that it will take for you to be assisted!

 

Thank you for being an active member of the Flow Community!

 

-Gabriel
Flow Community Manager

- Gabriel
Community Manager
Power Automate | Power Virtual Agents
Super User Program Manager



Anonymous
Not applicable

Yes, sorry!

 

Capture.PNGCapture2.PNGCapture3.PNGCapture4.PNGCapture5.PNG

Anonymous
Not applicable

Yes, sorry!

 

Capture.PNGCapture2.PNGCapture3.PNG

Anonymous
Not applicable

Also, these show up. Something about someone having it locked. I don't know if that's always the case.

 

Capture4.PNGCapture5.PNG

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (1,833)