cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Flow Works for Data originally populated but not with new

I have an Approved Drivers List. When I built the list I created a flow that runs every day and checks to see if someone's DL has expired and then email me .  The flow works works like a charm on the all the entries that were put in before I built the flow.  But it will not pop up with anyone that was added after the flow was built.  There only about 50 entries on this list.  The only thing I can think of that I changed is the view of the list.  I wouldn't think this would affect it but I figured i had better mention it.

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Flow Works for Data originally populated but not with new

Hi @glandrum,

 

Could you share a screenshot of your flow?

According to your description, it seems that you would like to send an email with items that have expired per day.

I have made the following test and the issue you mentioned could not be reproduced, all the items could be got when the flow is triggered though I have changed the view of the list and added some new items into the list.

It is configured likes below. For testing, I triggered the flow with a manual button.

Please check the following screenshot for a reference.

1.PNG 

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
New Member

Re: Flow Works for Data originally populated but not with new

Yes that is what is weird. When I build a test list and flow it works fine when I add new information. Recurrence Get Items apply to each Value Condition Checks the column of "notify of expiration" is less than or equal to UTCNow() The above looks like @lessOrEquals(items('Apply_to_each')?['mege'], utcNow()) Sorry I haven't figured out how to post screen shots
Highlighted
Community Support
Community Support

Re: Flow Works for Data originally populated but not with new

Hi @glandrum,

 

Which browser are you using? If you are using Chrome, I am afraid that you will have change to IE. Then in the Edit mode, click the Camera icon to upload a screenshot.

1.PNG

You mentioned that you have added a Condition to check if the column of “notify of expiration” is less than or equal to Utcnow().

What’s the exact column name and format of this column?

If it is named as “mege” and it is date only column, please try with the following formula.

@lessOrEquals(items('Apply_to_each')?['mege'], utcNow(‘yyyy-MM_dd’))

 

By the way, when comparing two dates, they have to be in the same format. Sometimes, we should use formatDateTime function to format the date to a required format. Please check the following doc on date and time functions for a reference:

https://docs.microsoft.com/en-us/azure/logic-apps/workflow-definition-language-functions-reference#d... 

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (8,348)