cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
andyolb28
Level: Powered On

Flow doesn’t upload a file to SharePoint SOMETIMES!

Hey,

 

I have 2 customers and they both have problems with a flow.

after uploading a file with power apps sometimes this file is not saved to SharePoint. Does anybody knows why?6BCA18F2-303D-45AB-AAEB-C3DE1CB4EE4F.jpeg

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Flow doesn’t upload a file to SharePoint SOMETIMES!

 

Hi @andyolb28 ,

 

I am afraid I don't know what the action you configured is, I guess it is Get items action.

And in Get items action, it seems that you have also configured Filter Query, so as the filter conditions change, the result returned by Get items may be an empty array.

Therefore, the actions in Apply to each will not be executed. The premise of the action execution in Apply to each is that Value is a non-empty array.

Hope it makes sense.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: Flow doesn’t upload a file to SharePoint SOMETIMES!

 

Hi @andyolb28 ,

 

I am afraid I don't know what the action you configured is, I guess it is Get items action.

And in Get items action, it seems that you have also configured Filter Query, so as the filter conditions change, the result returned by Get items may be an empty array.

Therefore, the actions in Apply to each will not be executed. The premise of the action execution in Apply to each is that Value is a non-empty array.

Hope it makes sense.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

andyolb28
Level: Powered On

Re: Flow doesn’t upload a file to SharePoint SOMETIMES!

Yes I built a loop and I repeat the get action... it’s working now!



 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (6,047)