cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ancorte
Helper II
Helper II

Flow doesnt' work for all elements of a list with attached files

Hello,

i have a list with attached file.

I made a flow that obtain the element of the list, and for every element, extract the attached file, rename it, and copy in a sharepoint folder.

It's all ok, except that this flow doesnt' manage all the element of the list. The flow finish without error message. The duration of the flow is about 7/8 minutes ( the  list contain about 200 elements). It' able to create the new attached file in sharepoint folder , but non for all attached files. The attached files have different name.

What can I do ?

Thanks for the help.

 

1 ACCEPTED SOLUTION

Accepted Solutions

@ancorte 

First, check the settings of the SharePoint Get Items action.  If you haven't already done so, turn pagination to "On" and set the threshold to a number no larger than 5000 (higher if you have a premium license).   Flow will only retrieve 100 items unless you make this change.

Once you have this set, run your Flow again and let me know if this resolves your issue.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

6 REPLIES 6
ScottShearer
Super User
Super User

@ancorte 

Please post screen shots of your Flow with as much detail as possible.  That will make it much easier to assist you.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
ancorte
Helper II
Helper II

Thanks, here a file in which a try to explain the flow.

 

 

ancorte_0-1631021678095.png

 

 

 

 

ancorte_1-1631021678100.png

 

ancorte_2-1631021678105.png

 

ancorte_3-1631021678107.png

 

ancorte_4-1631021678110.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The detail of Crea file is this :

 

 

ancorte_14-1631021769818.png

 

 

 

 

 

 

 

 

The details of “set variable” is this

 

 

 

 

@ancorte 

First, check the settings of the SharePoint Get Items action.  If you haven't already done so, turn pagination to "On" and set the threshold to a number no larger than 5000 (higher if you have a premium license).   Flow will only retrieve 100 items unless you make this change.

Once you have this set, run your Flow again and let me know if this resolves your issue.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

I've tried, with th elimit at 5.000 and paging on, but it's able to retrieve only 100 elements, as you describe.

What can i do ? Thanks for your help.

@ancorte 

Can you post a screen shot of the settings for your get items action?

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Here are the settings for get items action. Thanks

 

 

ancorte_0-1631082287827.png

 

ancorte_1-1631082287833.png

 

 

 

 

 

 

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (5,496)