cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ivazquez
Level: Powered On

Flow failed to fetch: getrunbook

Created a flow to trigger a runbook but everytime i add a runbook to the azure automation create job task an error pops up saying it failed to fetch:getrunbook! Is was working a few days ago but now all my automation flows are not working as configured.
23 REPLIES 23
Ruebyn
Level: Powered On

Re: Flow failed to fetch: getrunbook

We are having the same issue.  Additionally, whenever we edit an existing flow with an automation object, for example create job, parameters are cleared and the work flow breaks.

StaffanNelemans
Level: Powered On

Re: Flow failed to fetch: getrunbook

I am experiencing the same issues. An already correctly running flow, stopped working and cannot be repaired, due to the error: "failed to fetch: getrunbook"

azimmanjee
Level: Powered On

Re: Flow failed to fetch: getrunbook

Also having this issue.

Community Support Team
Community Support Team

Re: Flow failed to fetch: getrunbook

Hi @ Ivazquez,

 

I have made a test and the issue is confirmed on my side.

 

If  I choose a Runbook in the “Runbook Name” field of action “Create job” , the action would pop up the error
“Failed to fetch: GetRunbook”

 1.png

I would post this issue to my product team, if the issue is solved, I will reply here.

 

 

Regards,
Alice Zhang

WillShea
Level: Powered On

Re: Flow failed to fetch: getrunbook

Any news on when this will be fixed.  It is affecting a production process.   Thanks,

WillShea
Level: Powered On

Re: Flow failed to fetch: getrunbook

Is there somewhere that this can be escalated too?   This is causing me issues in production?  Please respond.

Ruebyn
Level: Powered On

Re: Flow failed to fetch: getrunbook

Could we please get an update on this issue? This is causing all sorts of processing issues within our tennant causing end-user complaints!

Ivazquez
Level: Powered On

Re: Flow failed to fetch: getrunbook

Verify the account register to perform the flow and the account that process the runbook, I granted permission and license the account that runs the flow and runbook and it started working again after replication.

DiNO
Level: Powered On

Re: Flow failed to fetch: getrunbook

I've created a new flow with a new account (full permissions to runbook / Azure Automation) and the issue still exist 😞

WillShea
Level: Powered On

Re: Flow failed to fetch: getrunbook

@Alice Zhang is there any update on this.   It is not like this is pre release functionality that was broken.  This is general release and should be made a priority.   Please update.

Ivazquez
Level: Powered On

Re: Flow failed to fetch: getrunbook

Make sure the new account have flow license and that same account has automation rights within your subscription account.
azimmanjee
Level: Powered On

Re: Flow failed to fetch: getrunbook

I am all licensed up, deleted and recreated the whole flow multiple times. All permissions are right. I get the same result: "Failed to fetch: GetRunbook"

Highlighted
Anonymous
Not applicable

Re: Flow failed to fetch: getrunbook

I have the same issue, but it only happens when I am not connected to my company's VPN, or on my personal device.  Very strange.

DiNO
Level: Powered On

Re: Flow failed to fetch: getrunbook

@Anonymous I tested it on several devices with/without VPN but I had no luck..

This time I used a new user with a complete E3 License and Owner role on the subscription, in my Case it doesn't help.

shakonarson
Level: Powered On

Re: Flow failed to fetch: getrunbook

Has anyone gotten a solution on this, I am having the same issue and this is affecting production environment.

shakonarson
Level: Powered On

Re: Flow failed to fetch: getrunbook

This all of a sudden works now, but I am not allowed to set the parameters for the runbook anymore. When in the flow I was able to pass values to the runbook parameters but that option does no longer exist, any idea on another approach / alternative?

Ivazquez
Level: Powered On

Re: Flow failed to fetch: getrunbook

Once the runbook ia created the first time and the parameters are set and saved, the parameters are not listed anymore, you have to recreatw the flow again to be able to set the parameters again.
shakonarson
Level: Powered On

Re: Flow failed to fetch: getrunbook

I still get the Failed to fetch: GetRunbook error message. I created a new runbook and copied the powershell code. There is no change.

 

This Flow ran fine 10 days ago but now it is broken and I also see the syntax of runbook with powershell has changed.

 

Does anyone here know what changed and why this is all of a sudden not working? I havent seen any response from Microsoft on this or is it not there responsibility to answer on this forum?

 

Ivazquez
Level: Powered On

Re: Flow failed to fetch: getrunbook

My mistake, what i meant was to recreate the flow task again not the actual runbook.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Users Online
Currently online: 113 members 5,287 guests
Please welcome our newest community members: