cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mariliu
Regular Visitor

Flow fails at send an email v2 with Unauthorized issue

I find out that my Flow can no longer send email although it could before. The only change I can think of is that I shared this flow with another person. Now even I no longer share, the Flow still cannot work. 

 

Error message is: 

 

{
"status": 401,
  "message": "Unauthorized\r\nclientRequestId: c8142a49-5fe1-4adc-a5f5-88abf96f0e42\r\nserviceRequestId: 696b0e24-b408-4904-a11f-8171bbbe21e4",
  "source": "office365-wcus.azconn-wcus-01.p.azurewebsites.net"
}
 
I read the link below, which describes the similar issue. But the solution does not apply to me. Please help.
 
4 REPLIES 4
Pstork1
Dual Super User III
Dual Super User III

Check to see who's context the connection is running under for the Flow.  That might have changed if the other person edited it after you shared it.  Are you using the From field in the advanced preoperties?  To use that the person who's account authorized the connection has to have Send as permission for the mailbox you listed in the From field.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Thanks. No one edit the Flow. I can't say that sharing causes the issue. It is just a fact that I remember. Basically, I shared, and then immedately tested the flow, and the flow failed. The flow could fail before I shared, I just did not test. 

 

I"m not using From field. This is my setting. The only change I made is to add a new email address in CC.

 

 

Annotation 2019-09-25 171105.png

 

 

Pstork1
Dual Super User III
Dual Super User III

I would start by removing the CC if that is the last thing you changed.  If that doesn't work start stripping things out until you are back to a basic email with static text.  If it still doesn't work then I think you'll need to open a service ticket with microsoft.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Thank you. That will be the last thing I should do...it's not too much difference than create a new Flow. And I thought that Microsoft Team support would reply here too. Am I in the wrong forum? I reported Teams issue before, and the Microsoft support helped.

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Users online (1,637)