cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RMD211
Resolver III
Resolver III

Flow in wrong environment triggering

I'm hoping someone can help me with this - I have a solution with an app and a couple of associated flows. I exported it as a managed solution from the Development environment to our Test environment.

 

When I go to use the Test App - the Development flows are being triggered, NOT the ones in Test.  Any ideas why? 

 

I can't edit the Power App in Test to remove/refresh the flow link as it's within a managed solution.  I've never had this problem before with a managed solution so unsure what's causing it.  It is even more strange as the Test App actually triggers two flows - one is absolutely fine, the other not. 

 

UPDATE:

I managed to open the app from the Power App portal - I noticed the connection for the flow was lost. RMD211_0-1657803975088.png

So I;

  • Removed the 'not connected' flow
  • Copied my existing code on my Submit button
  • Re-added the flow
  • Pasted in my code

But now it is not correct - my flow asks for 6 bits of data and the new connection expects 0??

RMD211_1-1657804025810.png

 

 

 

 

1 REPLY 1
ArchitectMadhan
Super User
Super User

Hi @RMD211 ,

 

Please make sure you have added the Power Automate Flow in the same solution where you have the Canvas App and refer the Flow from Power App. So that when you export the solution from one environment to another it will be taken as part of the solution itself.

- Architect Madhan

Please click the "Accept as Solution" button and give thumbs up, if it is helpful to you.

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (5,322)