cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jake1814
New Member

Flow is running once, but sending two teams messages

Hey all!

 

Here is the a link to a video of me scrolling through the flow in question Flow Video.mp4

 

Everything works fine and the flow will run successfully. 

 

However, the final step seems to be the one creating the problem and I don't know why.

This is what it looks like

Jake1814_0-1651190752719.png

However, what it actually outputs in Teams is this

Jake1814_1-1651190941129.png

The first message I have circled is perfect and exactly what I want but the second message seems to just pop-up right after the other for no reason.

 

Any help would be much appreciated.

Thanks!

 

P.S. right before I posted this I ran the flow again to make sure it wasn't running twice so here is the screenshot of the same thing happening in Teams, and proof that it only ran once.

Jake1814_2-1651191276114.png

Jake1814_3-1651191330305.png

 

 

2 REPLIES 2
ScottShearer
Super User
Super User

@Jake1814 

It appears as though your Reply in Teams action is inside of a loop - that will likely explain why it is executing more than once.

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Jake1814
New Member

@ScottShearer 
How do I get it out of the loop?

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (1,569)