cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

Flow is very slow

Hi @microsoft , 

 

I have a complex flow running on top of sharepoint list . 

Everything was working fine till now . Since few hours back , flow is taking long time to trigger and its really slow. SOmetime taking hours to run 

Is anyone else facing the same issue ? 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Flow is very slow

Hi @ssvk ,

 

Does the issue still exists?

I have made a test on my side and don't have the issue that you mentioned.

Please check if your flow still run slowly and please let me know if the issue still exists.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
Highlighted
Community Support
Community Support

Re: Flow is very slow

Hi @ssvk ,

 

Does the issue still exists?

I have made a test on my side and don't have the issue that you mentioned.

Please check if your flow still run slowly and please let me know if the issue still exists.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
New Member

Re: Flow is very slow

I have just started facing the same problem from yesterday. The flow that I created sends an e-mail to a customer who fills in a MS form. It was working fine and was sending the e-mails within two minutes. However from yesterday it is triggering about 2 to 3 hours later. Can anyone help me please?

Highlighted
Advocate II
Advocate II

Re: Flow is very slow

Hi @AhsanulAzad ,

 

Depending on the licence you have , flow can trigger only certain number of connector instances in fixed amount of time. 

For eg. triggering 500 connectors instances in 2 min .

In my case , the same was happening, as it has reached threshold value.

 

To avoid that - Instead of one flow - I am now using 4 flows, which does the same action , but doesn't reach threshold value.

 

Hope this would help you !

Highlighted
New Member

Re: Flow is very slow

@ssvk Thank you. I am giving it a try. Let's see.

 

Ahsan

Highlighted
New Member

Re: Flow is very slow

@ssvk 

Interestingly all my flows started working as before after I cleared my browsing history. I know it sounds bizarre but that's the result I got. All my flows are now behaving normal. I am on an E3 licence and I am using Chrome. Let me know if it works for you. 

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (7,678)