cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Flow - keeps failing - but still runs

Can any one help (i am very new to Flow)- i have a flow that keeps failing, however the flow Runs as expected and the emails are sent. So i guess it is a false positive.  

 

The flow is very simple - it checks the date in a column and if 30 days before the Renewal date or expiry date it will send a email to the Group. 

 

The below is the Error message i am getting - However the Flow Works

ActionFailed. An action failed. No dependent actions succeeded.

 

Unable to process template language expressions for action 'Check_product_expiry_date' at line '1' and column '2901': 'The template language function 'formatDateTime' expects its first parameter to be of type string. The provided value is of type 'Null'. Please see https://aka.ms/logicexpressions#formatdatetime for usage details.'.

 

Steps taken to Resolve and Flow Test  complete Successfully   - However the Flow DOES NOT Work

In the 'Check product Expiry Date' i have changed the Dynamic Content to the actual column Name (rather than the expression-

formatDateTime(item()?['jl0n'], 'dd/MM/yyyy'). the test passes but the flow does not find the any dates. my logic is that that there might be a mismatch of date formats and as such the expression puts them in all the same date format... but then i get the error, but it still works

 

Any help would great attached is the pictures 

 

ralph

Flow1.PNGFlow2.PNGFlow3.PNGFlow4.PNGFlow1-1.PNG

 

 
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

Re: Flow - keeps failing - but still runs

Hi @RalphC 

 

Apply to each action is error handled, so if it fails in one item it move to next, and this is what happening in your case. if you click on "Next Failed" you know for witch item your condition is failing.

Now the error that you are getting is because for few of the items (item()?['jl0n'] ) is empty.  so should  check if it is null before  format expression.

 

-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

 

View solution in original post

1 REPLY 1
Highlighted
Super User
Super User

Re: Flow - keeps failing - but still runs

Hi @RalphC 

 

Apply to each action is error handled, so if it fails in one item it move to next, and this is what happening in your case. if you click on "Next Failed" you know for witch item your condition is failing.

Now the error that you are getting is because for few of the items (item()?['jl0n'] ) is empty.  so should  check if it is null before  format expression.

 

-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

 

View solution in original post

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (6,232)