cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User III
Super User III

Flow on demand for a selected file: not available on Sharepoint Flow menu

Hi Microsoft Flow Team

I am building Flows on different Sharepoint libraries from the same Office 365 Group.

 

Last Month a created a Flow on demand for a selected file (let's call it Flow#1) on a library (let's call it library#1); everytime I access this Sharepoint library#1, click on a file and the click on Flow menu, the Flow#1 is listed (sometimes it takes several seconds, but it is finally displayed). I followed instructions given by @merwan in https://flow.microsoft.com/en-us/blog/flow-in-spo-document-libraries/

 

Two days ago I created a new library (let's call it library#2), and created a Flow (let's call it Flow#2) on demand for a selected file. Since then, everytime I access this library#2, click on a file and the click on Flow menu, the Flow#2 is NOT listed.

I've waited for more than a minute. Not listed.

I also tried yesterday & today. Flow#2 not listed.

I've tried with different browsers (Chrome, Firefox, Explorer). Flow#2 still not listed.

I've tried with Chrome incognito mode. Flow#2 still not listed.

I've created Flow#3 and Flow#4, on demand for a selected file in library#2. Flow#3, Flow#4 are NOT listed.

 

Please note Flow#1 is still listed in Library#1. Also Sharepoint New Experience is activated, the Flow menu is displayed and I can create new Flows from the Sharepoint library.

 

Is anybody else experiencing the same problem? If not, is there any Sharepoint or Flow administrator option that can block new Flows to be displayed?



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



1 ACCEPTED SOLUTION

Accepted Solutions

I used this for the first time a coupel of days ago and had the same behaviour as you, until I realised that the flow got created in a different environment than the default one. I recreated it in the default enviuronment and then it displayed...

 

Paul

View solution in original post

3 REPLIES 3
Community Support
Community Support

Hi @ efialttes,

 

Could you please share a screenshot of Flow#1 and Flow#2’s configuration?

Further, could you share a screenshot of items of Flow menu when you click on the file and click on Flow menu?

I have made a test on my side and don’t have the issue that you mentioned.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-xida-msft

First of all - thank you very much for looking into this!

 

Regarding this, I started getting support from @merwan and @KeremY on a different thread (https://powerusers.microsoft.com/t5/General-Flow-Discussion/Sharepoint-trigger-for-a-selected-item/t...). 

 

Regarding Flow#1 in Library#1 (the one displayed), it has more than 30 action blocks and several branches. Is it OK if I export it as a package (.zip) and share it with you via email, or by some other way? Please note I have executed it successfully this morning.

 

Regarding Flow#2 on Library#2 (the one that is not displayed), This are the steps I followed to implement it, you will see screenshots of the menu, the flow creation etc. If the image does not have enough quality please let me know and I will upload them one by one

FlowSPLibrarySelectedItem.png

 

This morning I also tried to create a new Flow (Flow#5) at Library#1, in order to see if the proble is related to the library configuration. The result was the same as with Flow#2 in Library#2. Once I select a file from the library, Flow#5 is not displayed on SP Flow Menu. So, the problem is not the library configuration itself.

 

Since it is working for you, there must be something in my testing scenario different than yours.

I am working with a Sharepoint belonging to an Office365 Group. I also have two Flow environments (preview & default). Could any of these details be the difference?

Thank you in advance!

 

 

 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



I used this for the first time a coupel of days ago and had the same behaviour as you, until I realised that the flow got created in a different environment than the default one. I recreated it in the default enviuronment and then it displayed...

 

Paul

View solution in original post

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (68,954)