cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Kudo Kingpin
Kudo Kingpin

Flow running ok two weeks ago is failing now: Sharepoint List to email

Hi all

I had a flow that was working fine some weeks ago. This morning every execution fails.

The trigger is "When a new sharepoint item is created", the visual logs reports the trigger itself is executed but fails:

 

Outputs
  • Body
    { "status": 401, "message": "{\"error_description\":\"Exception of type 'Microsoft.IdentityModel.Tokens.AudienceUriValidationFailedException' was thrown.\"}",

 

Last week I changed my corporate password, can this be the reson for this failure?

When I check "My connections", it seems everything is fine...

Please see screenshot attached

 

sharepoint_error.png

10 REPLIES 10
Microsoft
Microsoft

Hi Efialtes,

 

I will create incident to find this root cause.

 

Would you mind to share the flow id ? (or just share this url)

it should be in the url. /manage/flows/xxxxx

 

 

Thanks

For our tracking here is the incident number #20287429

@kkurni

Thank you for your fast response. Here you are the flow ID

04396c82-876f-4a96-8780-d018229bcc6b

 

 

Thanks @efialtes.

 

Btw would you mind to send us screenshot for your sharepoint connection  as well ?

 

Thanks

@kkurni

On my initial post I included a screenshot showing the runtime the error and at the bottom of that image you will see also the sharepoint connection status. I took it yesterday, if you need the status it is showing today, please let me know.

 

BTW, I tried to build a new flow starting with the same sharepoint trigger, and as soon as I configure the Site URL my flow editor displays a similar error:

 

{"error_description":"Exception of type 'Microsoft.IdentityModel.Tokens.AudienceUriValidationFailedException' was thrown."}

 

I haven't tried yet to delete the connection and create it again, since I guess it will force me to delete and rebuild all related flows

 

Thanks!

 

Ah I now see your connection seems to be fine.

Ok. I will debug this and bring this up to connector team. I will update you as soon as i have an answer.


Thanks

Regular Visitor

Hi, I am also having the same trouble. Flows were working a few weeks ago, however now contains error message

 

When a new item is created in a list:

 

{"error_description":"Exception of type 'Microsoft.IdentityModel.Tokens.AudienceUriValidationFailedException' was thrown."}

 

List Name: baaa9981-92c6-4e22-9d95-f816f5b866f2 (rather than actual List Name)

 

 

 

This is occuring in all similar flows that have been created. Was working perfectly previously.

Power Apps
Power Apps

Flow doesn't expose a way to force a re-auth for a connection, but you can try it through the PowerApps portal (https://web.powerapps.com). Your same connections will show up there, and if you click on your sharepoint connection, there will be a little key icon in the top right corner that will trigger the authorization again. Hopefully that will at least workaround your issue while we find the root cause. Otherwise, deleting and re-creating connection would be the last resort.

 

ReauthConnection.PNG

 

 

 

Hello, last morning I had to change my office365 password (as each two months for security purpose). This morning i lost all my connexions to any list in my sharepoint online portal, unable to connect to any list too and impossible to have any of my yesterday working flows functionnal anymore. Does anybody have a solution for this trick ?

 

Best Regards.

 

Eric

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (9,004)