cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Flow sends wrong email when Approver responds "Approve"

Hi I have built a flow where teachers can request professional development in forms and then their request is sent to a line manager. 

 

However, when the line manager approves the PD request the flow sends the user back "Your PD has been unsuccessful" which is the event triggered by a reject action on the line manager side. I have attached a screenshot of the flow. Can't figure it out!2019-07-26 12_37_40-Edit your flow _ Microsoft Flow.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User II
Super User II

Re: Flow sends wrong email when Approver responds "Approve"

@rupertdenton 

Hi there - Try changing the condition from "Responses" to "Outcome", leaving the criteria as "Approve".  I'd also suggest losing the Apply to Each loops by getting rid of anything has "responses" in the label.  Just until we figure this out.

 

Keep us posted.

-Ed-

 

 

If this reply has answered your question or resolved your challenge, please consider marking it as a Solution. This helps other users find it more easily via search.

View solution in original post

3 REPLIES 3
Highlighted
Super User II
Super User II

Re: Flow sends wrong email when Approver responds "Approve"

@rupertdenton 

Hi there - Try changing the condition from "Responses" to "Outcome", leaving the criteria as "Approve".  I'd also suggest losing the Apply to Each loops by getting rid of anything has "responses" in the label.  Just until we figure this out.

 

Keep us posted.

-Ed-

 

 

If this reply has answered your question or resolved your challenge, please consider marking it as a Solution. This helps other users find it more easily via search.

View solution in original post

Highlighted
New Member

Re: Flow sends wrong email when Approver responds "Approve"

Thanks Ed, that worked! Amazing. Can you explain why that worked versus my responses version? 

Highlighted
Super User II
Super User II

Re: Flow sends wrong email when Approver responds "Approve"

Hey there! 

So, a while back I think they changed the name of the field from "response" to "outcome". Also, I think the "responses" fields are to track the individual responses when you have the approval go to more than one person.  I've noticed that any time I chose a field that was plural, like "Responses", it would trigger an Apply to Each loop.

I think that's because there could be many responses for each approval, but really only a single "outcome".

 

As far as why the wrong email was sent, I'd look at the actual field in the criteria, and then the data being sent by the approver.   Is there only ever one approver?

Either way, glad it's sorted out.

-Ed-

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (7,392)