cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
golfnutt8
Helper I
Helper I

Flow starts but wont move to the next action

I am currently entering an item into a SharePoint list and then from the list I am initiating a workflow.
The workflow starts but wont continue and seems to be stuck at update item.
I am new to Power Automate and hope to learn this tool quickly now that SP 2010 Workflows will be removed by 11/01/2020.

golfnutt8_0-1601560228512.pnggolfnutt8_1-1601560347448.png

Thx for the help!

1 ACCEPTED SOLUTION

Accepted Solutions

Have you saved it and tried running it after the changes?  AS you can see below I'm using the same two things in a flow with no error. I suspect it must be a false positive based on the changes that have been made.

image.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365EduCon in Chicago on Sept. 26-30 where I'll be presenting on the Power Platform!

View solution in original post

7 REPLIES 7
Pstork1
Dual Super User
Dual Super User

It looks like you are using two triggers in your flow, both For a selected item and when an item is created.  That won't work.  There are very rare cases where you can use a second trigger, but in general you only use one trigger per flow.  Either it is initiated when a new item is created or manually when you select a specific item, but not both.  You are kicking the flow off manually, but then it is waiting for that item to be created.  Since it already exists it will just sit there.  Remove the duplicate trigger.

 

In SPD you could have multiple startup conditions, but in flow you only have one trigger.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365EduCon in Chicago on Sept. 26-30 where I'll be presenting on the Power Platform!
Anonymous
Not applicable

PA Missing Trigger Error.JPG

f I remove everything beside the first trigger then I get the missing trigger error above.

 
I believe I need the first trigger "When an Item is Selected" for the manual piece so that my List reflects the API flow name so the flow can be started manually.
The manual piece is working great but I need to trigger another workflow once the item is created, which is why you are seeing the initial part of the workflow.
My reasoning behind what I was doing is that I needed the other trigger "When and Item is Created" so that I could continue to build the rest of the approval workflow.

If I am not configuring this correctly, I would appreciate some constructive feedback.

Thanks!

The error is because you've removed all the actions and left only the trigger.  A flow must contain one trigger and one or more actions.  Add an action of some type and the error should go away.  

 

If you want to trigger one flow manually and another automatically then you need two separate flows.  You can't do them as a single flow like you could in SPD.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365EduCon in Chicago on Sept. 26-30 where I'll be presenting on the Power Platform!

Here I have one trigger - "For a Selected Items"

Here I have one action - "Send an Email Notification"

Without "When an Item is Created" I see the following:

golfnutt8_0-1601567184021.png

I have no dynamic content without "When an Item is Created" trigger.
Any other ideas as to which direction I need to go?


Have you saved it and tried running it after the changes?  AS you can see below I'm using the same two things in a flow with no error. I suspect it must be a false positive based on the changes that have been made.

image.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365EduCon in Chicago on Sept. 26-30 where I'll be presenting on the Power Platform!

Hello,
Ok, I assumed that when the error appeard and a red dot showed up at the left telling me my workflow had an error, I would not be able to save it. 
I was able to save the workflow!

Thank you for your assistance.

The error appears after the error checker runs.  Until you try to save it after making changes the error checker doesn't update, so the error doesn't go away until you manually run the error checker or try to save.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365EduCon in Chicago on Sept. 26-30 where I'll be presenting on the Power Platform!

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,049)