cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gazzo1967
Impactful Individual
Impactful Individual

Flow times out on send email with attachment

Hi all

I have a flow which takes response from a form.

After Get response details i have a parellel action to create item in sharepoint list and to create a pdf from a word template which is then attached to an email and sent.

The problem is that the flow works fine (run time around 60 secs) until i add the attachment to the flow. (which i add as shaepoint File Name and File Content.

When i add the attachment it times out.

The attachment file is only 150kb in size.

Any ideas?

regards Gary

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @gazzo1967 

 

Can you share details on the action : When a  file is created in a folder from LM? Is this the when a file is created trigger? If so, please note that you cannot use two triggers in flow. You will have to get rid of this and instead use the identifier to get the file. 

 

I want to see how you are addding the attachment in the emai.. Can you share an expanded screenshot of the send email action where you have the attachment section? Also, why are you using two parallel email actions? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

4 REPLIES 4
yashag2255
Dual Super User II
Dual Super User II

Hi @gazzo1967 

 

There might be an error in formatting the attachment or getting it from sharepoint. We can be certain about it we we can see the flow and the error that you are getting. Can you please share the screenshots of those? 

 

 

gazzo1967
Impactful Individual
Impactful Individual

@yashag2255 

Here is my flow

The left branch just populates a sharepoint list with create item.

Send email V" is the action that needs to have the attachment.

can't understand why the PDF could be bad as it opens up fine when clicked directly!

Regards Gary

Capture10.JPG

Hi @gazzo1967 

 

Can you share details on the action : When a  file is created in a folder from LM? Is this the when a file is created trigger? If so, please note that you cannot use two triggers in flow. You will have to get rid of this and instead use the identifier to get the file. 

 

I want to see how you are addding the attachment in the emai.. Can you share an expanded screenshot of the send email action where you have the attachment section? Also, why are you using two parallel email actions? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

gazzo1967
Impactful Individual
Impactful Individual

@yashag2255 

I actually found my error which was i had file content and file name the wrong way round.

Changed them an it worked fine..

 

The reason for 2 emails is one is an acknowledgement to the sender the other is a prompt for someone to act... different content in each body.

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (1,360)