cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Flow trigger failing on form submission

I'm trying to get Flow to email me when an office form is submitted. The flow run history summary says "trigger failed" but doesn't say why it failed. There are no notifications in Flow or Forms that indicate anything is wrong. How can I figure out why the trigger is failing?

 

Thanks,


Jeff

 

flow2.PNG

 

triggerfailed.PNG

2 ACCEPTED SOLUTIONS

Accepted Solutions
Community Support
Community Support

Hi @jbentivoglio@miliscm,

 

I just tested with the same trigger but mine runs successfully

Capture.PNG

 

Although there is almost 1 hour's delay. Would you please try to create a new one to test?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Frequent Visitor

With the recently announced email notification now built into forms I have turned off all of my email notification flows. So far the new notifications are working as expected.

 

https://techcommunity.microsoft.com/t5/Microsoft-Forms-Blog/New-notification-features-in-Microsoft-F...

 

View solution in original post

10 REPLIES 10
Advocate I
Advocate I

I have the same problem.

When there is a new response in forms, you are not sending mail from flow.

teste001.JPGteste002.JPG

Community Support
Community Support

Hi @jbentivoglio@miliscm,

 

I just tested with the same trigger but mine runs successfully

Capture.PNG

 

Although there is almost 1 hour's delay. Would you please try to create a new one to test?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi , @v-monli-msft

Actually, I waited an hour and the flow worked. I realized that it only works every one hour. Only the task will run after one hour. Thank you for your attention.

Frequent Visitor

Mine also worked but after several hours. I don't think that's the way its supposed to work but maybe it was just a glitch.

I have the same issue, however I submitted the form over 5 hours ago and the trigger hasn't run. I've tested multiple scenarios and the email only triggers if I make a save to the flow, or toggle it off then on. It then sends an email, but this only triggers for responses made recently (within an hour or so), one made several hours before didn't send an email or have any record in run history. 

 

I can't find any known issues with this but it clearly isn't reliable. Can anyone offer advice to help get this working?

New Member

I'm seeing similar erratic performance. Sometimes switching off/on fixes. Seems to be hitting forms that do a Sharepoint lookup the most for me.

 

No errors to act on. 

Hi all,

 

The issue about Forms trigger has been realized by pg and they are working on it. Sorry for the inconvenience.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Frequent Visitor

With the recently announced email notification now built into forms I have turned off all of my email notification flows. So far the new notifications are working as expected.

 

https://techcommunity.microsoft.com/t5/Microsoft-Forms-Blog/New-notification-features-in-Microsoft-F...

 

View solution in original post

Hi Mona,

 

I had a call in on this but it went quiet after a similar answer. Is there anywhere we can follow progress on this issue to save us hours of needless trouble shooting?

New Member

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (7,068)