cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
lallison
Level: Powered On

Flow

Hi, I am having trouble building a flow or even using templates.
Also how can I run the flow directly in the library. Flow button is there but not showing any created flows below.

Template: "When a file is added, approve file using SharePoint Content Approval."
If I select Test - I'll perform trigger action = very slow, after about +-10 minutes the following error pops up: "Flow run timed out because the starting action was not performed. Please try again."

Blank Flow Created for Approval:
Test Flow - Using data from previous runs = Error" InvalidApprovalCreateRequestAssignedToNoValidUsers" / "Required Field 'assignedTo' contained no valid users in the organization"
(Note, they are valid users, even tried my admin username and email)

If I select Test - I'll perform trigger action = very slow, after about +-10 minutes the following error pops up: "Flow run failed"
2 ACCEPTED SOLUTIONS

Accepted Solutions
Super User
Super User

Re: Flow

@lallison 

You have a number f options that will ease your pain.

First, it looks like you want the Flow to run automatically when a new file is added to a library.  These type of Flows will not appear on the Flow drop-down list above the library.  Once you create them, they will just run with no need to share the Flow with any other users just like a standard SharePoint Designer workflow that runs when an item is added..  In other words, there is no need to have a copy of the Flow for each user.  I might be missing something - can you tell me why it was necessary to change the connection info?

 

You mentioned that you have to us the same Flow on numerous libraries.  You can export the Flow and then import as a new Flow.  After importing, all you'll need to do is change which library the trigger is pointing to and also change any other SharePoint action to point to the new library.  This entire process should only take a few minutes for each library.  There is no concept in SharePoint of anything like a reusable Designer workflow. You'll find the export option on the menu at the top when on the Flow properties page.  You'll find the import option at the top of the Flow screen listing all of your Flows immediately to the right of New.

If  you have additional questions, please post here.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

lallison
Level: Powered On

Re: Flow

Hi Scott,

 

I did manage to resolve the issue, weird one and took me a while to see where the issue was. Due to the performance it seems that if I save it sometimes has not changed/initialise immediately, takes a few seconds. Now in the habit of double checking all the assigned to after making changes.

 

As you said - very inconsistent

 

Thank you so much for you assistance.

View solution in original post

8 REPLIES 8
Super User
Super User

Re: Flow

@lallison 

The Flow template that you are using requires that content approval be enabled on the library.  To do so, click on the Flw drop-down in the library and click on Configure Flows.  Set "Do you want content approvals" to Yes and Select Content Approval.

DocApp.jpgDocApp1.jpg

 

There may be other things wrong in the Flow configuration as well - there are items that must be properly configured in the template for it to run.

 

Can you post a screen shot of one of the Flows with which you are having an issue and let me see if I can assist?

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
lallison
Level: Powered On

Re: Flow

Hi Scott,

Thank you for the quick response, really hope I can get this sorted out for my client.

 

Flow issues.JPGFlow issues1.JPG

lallison
Level: Powered On

Re: Flow

Hi

 

I have sorted out the issue. I have a few clients therefore a few SP/ MS usernames / Passwords.

 

Even thought when I connect via Flow with the correct username/password and the template flow also showing the correct connections there is still other connections incorrect.

I have to go to Data > Connections and change each connection individually, but due to performance issues (Flow is very slow and intermittent) it sometimes do no change the connection, I now force myself to go back 2x to ensure all are correct - then only can I continue.

Any better suggestions than current steps below on how to handle multiple accounts will be appreciated.

Step 1: Disconnect from current Flow

Step 2: Close browsers

Step 3: Reconnect Flow to the new client account

Step 4: Data > Connection and change each and every connection to the new client account

Step 5: Select Data > Connections and verify accounts

 

Thx Scott, your quick response is appreciated

 

General:

Flow is VERY... VERY Frustrating

Thinking of the days of SP designer - this is a downgrade with the performance and certain functionality not working or taken away.

 

One if the issues I am now facing is, I have 30 libraries that needs approval flows - can Flow do reusable flows?

 

Super User
Super User

Re: Flow

@lallison 

You have a number f options that will ease your pain.

First, it looks like you want the Flow to run automatically when a new file is added to a library.  These type of Flows will not appear on the Flow drop-down list above the library.  Once you create them, they will just run with no need to share the Flow with any other users just like a standard SharePoint Designer workflow that runs when an item is added..  In other words, there is no need to have a copy of the Flow for each user.  I might be missing something - can you tell me why it was necessary to change the connection info?

 

You mentioned that you have to us the same Flow on numerous libraries.  You can export the Flow and then import as a new Flow.  After importing, all you'll need to do is change which library the trigger is pointing to and also change any other SharePoint action to point to the new library.  This entire process should only take a few minutes for each library.  There is no concept in SharePoint of anything like a reusable Designer workflow. You'll find the export option on the menu at the top when on the Flow properties page.  You'll find the import option at the top of the Flow screen listing all of your Flows immediately to the right of New.

If  you have additional questions, please post here.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

lallison
Level: Powered On

Re: Flow

Hi Scott,

 

Thank you for the feedback.

 

In regard to the connections, I have various client with different usernames/passwords. If I log on with a specific username/password for a client it does not automatically update the Outlook connection etc... .

 

Thx for the export / import option. Will give it a bash.

 

 

lallison
Level: Powered On

Re: Flow

Hi

 

Seems to be back at square one.

 

The best template to the client needs will be 'when a file is added, approve file using SharePoint Content Approval'.

 

I have a library with a "Approver" column (Person/Group / single entry). When the user uploads a document he assigns a Approver using the Approver column.

Within flow the "Assigned to" only allows for email address and therefore I am getting an error when I use the Dynamic content (Approver).

I have tried a few suggestions but very messy and just going around in circles.

 

Any suggestions? or alternative flows that will accommodate.

 

Greatly appreciated

Linda

 

 

Super User
Super User

Re: Flow

@lallison 

If you have configured the Flow template properly and the Approver column is a person or group column, you should be able to select the email address of the person mentioned in the person or group column from Dynamic properties.

In my example below, I have added a person or group column called My Approver to the library.

ApprovalTemplate1.jpg

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
lallison
Level: Powered On

Re: Flow

Hi Scott,

 

I did manage to resolve the issue, weird one and took me a while to see where the issue was. Due to the performance it seems that if I save it sometimes has not changed/initialise immediately, takes a few seconds. Now in the habit of double checking all the assigned to after making changes.

 

As you said - very inconsistent

 

Thank you so much for you assistance.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,566)