cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hubertlam
Advocate II
Advocate II

For a selected file trigger - returned encrypted user email

I've created a Flow in which it uses the For a selected file trigger on a SharePoint Document Library.

 

It then tries to extract the email address of the user who triggered the Flow, however, the email address returned is encrypted!

 

Can anyone else replicate this?

 

Extract the email address of the user who triggered the FlowExtract the email address of the user who triggered the Flow...email address returned is encrypted!...email address returned is encrypted!

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @hubertlam ,

 

I'm afraid that the issue is caused by microsoft and now the issue has been fixed.

Since your problem has been solved, please go ahead and mark the post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
hubertlam
Advocate II
Advocate II

OK - just found out that this is Base64 encoding:

 

image.png

 

 

Anyone know how to decode from base64 back into plain text?

What the heck?!?! It's now working again.

 

Someone has been tweaking the encoding behind the scenes!

Hi @hubertlam ,

 

I'm afraid that the issue is caused by microsoft and now the issue has been fixed.

Since your problem has been solved, please go ahead and mark the post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

It appears it's not fixed. Mine just started having this issue last week (10/11/2019)

 

Any suggestions.

kitUser
Frequent Visitor

I am currently experiencing this issue since yesterday, 10/29/2020. Anyone else having this issue? 

Update: I was able to create a new flow as a work around for this issue. It is unfortunate to have to transfer all my actions to the new flow to resolve this issue. 

email_encrypted1.PNG

email_encrypted.PNG

 

email_encrypted_query.PNG

email_encrypted_query2.PNG

calebmfoster
New Member

I think I've found a work around as of 2/25/21:

How to avoid corrupt email attachment in Power Automate (tomriha.com)
I believe the formula snippet could be applied to other parts of the email as well

format:
base64ToBinary([Attachments Content])

note: [Attachments Content] is a dynamic content

when using in a flow, it could look like this:
base64ToBinary(items('Apply_to_each')?['contentBytes'])
 

 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (99,771)