cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RSNZ
Frequent Visitor

Forms Trigger - Flows in tracker report they're running even though they've supposedly completed.

I have created a flow that triggers off "Forms - When a new response is submitted" and runs through an apply to each which uses the Forms List of Responses. This runs through an approval and creates a sharepoint item in a list/send an email or sends an email depending on the approval outcome.


The approver tells me that he has received the approvals and approved them, i've checked and it definitely looks like sharepoint items have been created but the flow tracker shows them as still running and not even having started the approval process. I cannot find any errors, my connector is reporting as OK, the flows are simply showing as waiting to start the Apply to Each section. Has anyone experienced something similar? Images of flow tracker and individual flow progress below.

 

image.pngimage.png

2 REPLIES 2
v-bacao-msft
Community Support
Community Support

Hi @RSNZ,

 

 

Could you please share a full screenshot of the configuration of your flow, especially the configuration Approval by HSE Manager?

 

I have made a test on my side and don't have the issue that you mentioned.

 

Image reference:

 

25.PNG

 

The flow works successfully as below:

 

26.PNG

 

You could try to resubmit it and feel free reply back if issue still exist.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Barry, Thanks for your reply. I could resubmit them but i'm trying to figure out why the tracking doesn't seem to be registering that they have finished the run through. I could understand them being held up if a connector was broken or something but both creating the sharepoint item and sending the email required an active connector or they would've failed with 401. Both of these steps have definitely completed.

 

The flow definitely has worked as the form has 27 submissions on it and ~80% of them have run through and tracked as suceeded.

 

Some of the historical runs did seem to update the status in the flow tracker a little bit slowly when i was monitoring them (i.e. Approval completed(email sent, sp list item created) but it shows as running for another 2 days before it finally ticks over to succeeded. Full flow posted below

flo.PNG

 

 

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Super User 2 - 2022 Congratulations 768x460.png

Welcome Super Users

The Super User program for 2022- Season 2 has kicked off!

Users online (4,504)