cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Get List Items filter returns no data

Hi there,

I'm filtering a list by ID with a field from a completed adobe agreement. The field holds the SharePoint list ID (SPID) that triggered the creation of the original form and now I just want to attach the completed PDF to the list. 

ListID.png

When the flow runs there is no result form this task

No OutputNo Output

There is a parse JSON result that shows the correct list item ID

SPID.png

 

I expect the filter should be saying ID eq 7 but I can't see why no list item is returned. 

Can anyone offer some advice?

 

Regards, Dale

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Get List Items filter returns no data

 

Hi @dflemming ,

 

Please try to use int() function to convert the string id to Interger.

Besides, please make sure the list contains an item with ID 7.

Image reference:

88.PNG

Hope this helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Highlighted
Frequent Visitor

Re: Get List Items filter returns no data

Hi @dflemming ,

 

Instead of using Get Items action you could use Get Item Actions the one without (s).

 
 

Pass your 'SPID' from JSON Parse output in Id property of Get item.

 

If it helps you, please accept as solution.

Thank you @dflemming 

Highlighted
Community Support
Community Support

Re: Get List Items filter returns no data

 

Hi @dflemming ,

 

Please try to use int() function to convert the string id to Interger.

Besides, please make sure the list contains an item with ID 7.

Image reference:

88.PNG

Hope this helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Frequent Visitor

Re: Get List Items filter returns no data

This is great advice but I have found that when I try and work with the SPID is always seems to be null. I'll have to try another approach.

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (10,989)