cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
asdfaf4
Kudo Collector
Kudo Collector

Get a Form ID...

I'm creating a flow that is supposed to trigger when a new form is created.  Sadly, the trigger action requires a form ID but doesn't list the form.  The form doesn't show in my pulldown menu, it was created and shared by someone else.  I'm pasting the name of the form but only getting Flow errors.

 

Where can I get the form ID?

Why does the form doesn't show up in my pulldown menu in the action?

23 REPLIES 23
v-xida-msft
Community Support
Community Support

Hi @asdfaf4,

 

Could you please share a screenshot of your flow’s configuration?

Could you show a bit more about the error message of your flow?

Further, how does someone else share the form with you?

I suppose that you use “When a new response is submitted” of Microsoft Forms connector as a trigger, if you create a connection to “When a new response is submitted” trigger with your own account, you could only achieve the forms that created by you. Please check if the form exists in your own Microsoft Forms.

If you want to use the form that shared by someone else, please take a try with the following steps:

  • Someone else should share the form as a template with you:2.JPG

     

  • Please type the URL link in browser and sign in Microsoft Forms with your own account. In opening web page, click “Duplicate it”:3.JPG

     

Then the form will show up in your own Microsoft Forms as a copy one:4.JPG

 

  • Now create a connection to “When a new response is submitted” trigger with your own account and you can use the form in Microsoft Flow:5.JPG

     

Bets regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
v-xida-msft
Community Support
Community Support

Duplicate

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
alexanderwgran2
Advocate I
Advocate I

Hi,

 

Click Send and collect responses. Then copy the text in the link after id=

Insert this text in the pull down menu. This works for me 🙂

Thank you. This solution helped me perfectly.

SebastienLecoq
New Member

Hi all,

I'm facing the same issue while creating this flow.

I'm the creator and owner of the O365 group and Forms I'm trying to automate but still the menu doesn't show any forms (no element) in the selection...

I can't get any ID in forms, so I'm clueless.

Does someone has an idea?

flow.jpgforms.jpg

Hello,

Sorry for the answer in french, it will directly help Sebastien

 

@SebastienLecoq Sébastien,
Dans l’éditeur du formulaire, clic sur "partager".
Dans le bloc "Envoyer et recueillir les réponses", récupère le lien.
Dans le lien, l'id est indiqué (copie le), c'est une longue liste de caractères en fin de lien après "id="

 

Après dans ton flow, sélectionne dans la liste déroulante "entrée une valeur personnalisée" et copie l'id.
Je viens de le faire dans un cas similaire au tiens est cela marche.

 

Bonne journée

Bonjour,

 

Merci beaucoup, ça fonctionne bien !

Pour incorporer du contenu du formulaire dans le corps du mail c'est encore une autre affaire... je vais fouiller un peu.

Hello,

It's not working for me...why ?

 

Bonjour,

J'ai essayé votre méthode, ça ne marche pas...pourquoi ? 

bee87cbe-30d0-438e-96ba-5ed79609e374, Id. de correlación: 899a6124-4345-43d7-b941-a492e6f1d43c

The dropdown is only for my forms (annoying)

However, you can enter a custom ID

The flying polymath had this covered in https://youtu.be/sVzB1wdrIKE from 10:54 onwards

basically, is on the URL from FormID="xxxxxxxx to the bit ending wcu"

This needs marked as the solution.  Good job!  I'd also like to add to this.  We had someone build a complicated questionnaire form but this individual is no longer with the company.  He also build a flow to connect the input form data to SP list backend.  So I had to take ownership of the form using a delegate URL to find the form.  Then I 'moved' the form to an IT M365 Group for ownership.  Well, I couldn't 'see' the form from the flow after I did this!  And once I picked up the ID as described in your comment, it worked just swell.  As a side note, the flow was another problem so i ended up logging with the old user account to transfer ownership.  We need better admin methods with Power Automate/Apps and forms.

Stephen_Bisang
Frequent Visitor

Please mark as solution.  This seems to be a disconnect between Automate and Teams to fetch Group Form ID.

Yes, figured this out too, Automate ties users to Personal Forms, even if you transfer to Group Forms.  I think a lot of admin on the platform are figuring out how to govern Group Flow Bots to run processes vs them being tied to users.  

you just saved my life now

alexanderwgran2
Advocate I
Advocate I

Happy to help

Group Forms allow for so much more flexibility in terms of automation, privacy, and management of the form the data by sending to an excel doc in your Group's SP back end.  You can then send an http call to your form and delete the data from the Forms server and it still stays in your SP back end for preservation.  

 

@Scott0044 - Yes, I've experienced the same issue with flow ownership, I can't wait for service accounts at my work so this becomes less of a hassle.  People aren't aware of all the connections in Automate, and that you need to export/import the flow from one user to another.  It also makes it challenging when you're using these user "claims" connections to try to actually to capture other user interaction data in the flow without having the user modify items.

Raj96
New Member

Hi,

 

I am new to this platform. But please mark this as a solution if this fix your problem.

 

Step 1 :- Make sure you are in "My Forms". Go to - My Forms

Raj96_0-1658467487967.png

 

Step 2:- Click +New Form.

Raj96_1-1658467628878.png

 

Step 3:- Create a form here and then go to power automate > Template > Select one > and then Find ID will populate the form you recently created.

Raj96_2-1658467798614.png

This now should be available in your power automate flow.

Raj96_3-1658467884384.png

Hope this helps. 🙂

 

Thank you!

DanielG1000
New Member

I have got a similar problem: all the solutions in this thread work when it is a form owned by myself. But I want to use one that is owned by my organistion WITHOUT copying it to my list of forms. Do I need to enable some admin rights?

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (1,520)