cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DeanvH
New Member

Getting data from an excel table

Hi

 

I'm just new to Power Automate while I've been able to find answers so far on the forum via other past examples I'm a bit stuck here and need some help.

 

I am trying to send an automated email to my service manager when a piece of equipment reaches a certain number of engine hours or a certain length of time since its last service

   

I have automated a digital log book already via forms and a flow and the rows in the excel table are getting updated with the engine hours and date each day someone uses the machine

 

I've created a basic algorithm in the second tab of the spreadsheet to return a 1 if an email reminder is required or 0 if it isn't required based on the date and the hours.  The algorithm works fine and is populating the main tale with a 1 or 0 accordingly

 

All i want to do with this flow is determine if the Service Reminder (Column D) is a 0 (zero) meaning no reminder email is required or a 1 (one) a service reminder needs to be sent 

 

I'm getting two errors.

If the table has a value of 0 when the flow runs I get an error saying "No row was found with Id '1'."  at the Get a Row stage 

If the table has the value of 1 when the flow runs no emails are sent as the condition, which I'm thinking should be when 1 is equal to 1, comes up as false 

 

Obviously I'm not assigning the correct Key Value in the Get a Row Action but I'm not sure what else to put

Also, is the output from Get a Row the actual data string or figure from the relevant cell in the table ?

 

Any help would be appreciated as this has been driving me mad for days trying to find a solution

 

Thanks  

 

 

DeanvH_0-1597894823930.png

 

DeanvH_1-1597895288587.png

 

DeanvH_2-1597895612314.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-bacao-msft
Community Support
Community Support

 

Hi @DeanvH ,

 

You could consider removing the spaces in the field names, please refer to this similar thread and see if it helps:

Solved: No row was found with Id '1', however I am checkin... - Power Platform Community

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-bacao-msft
Community Support
Community Support

 

Hi @DeanvH ,

 

You could consider removing the spaces in the field names, please refer to this similar thread and see if it helps:

Solved: No row was found with Id '1', however I am checkin... - Power Platform Community

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks Barry

 

I managed to figure out the problem in the meantime 

I added an ID column to create row numbers for the Key Value

 

Thanks for responding  

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (2,933)