cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lguest
Level: Power Up

GoToWebinar Connection continually disconnecting

We are using the GoToWebinar connector within Flow to manage our webinar registrants. The flow is triggered when a posted form from our website is submitted which creates a record in Dynamics CRM (this is the trigger that starts the flow), from there we determine if the posted form was an upcoming webinar form and from this we do a get lead/contact record. The record is then added to GoToWebinar as a registrant and sent an Outlook meeting invite with their specific registrant join URL which is created by GoToWebinar. 

When the connection is active, this Flow works great, however if the Flow is inactive for longer than a 15 - 20 min time window, the connection fails and the next user that registers does not receive any GoToWebinar details as the Flow failed. 

I even tried setting up a template with the GoToWebinar directly from Microsoft and was still having issues with the connection. We have not changed any credentials to our GoToWebinar account.

Is anyone else having issues keeping their GoToWebinar connection active? 

3 REPLIES 3
v-zhos-msft
Level 10

Re: GoToWebinar Connection continually disconnecting

Hi @lguest ,

Could you please share a screenshot of failure Run history with the error message?

I am confused about that why the connection will be inactive.

You can check the connection status in the flow:

If the status is connected, it means there is no problem of the connection.

InkedCapture3_LI.jpg

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Rockman
Level: Power Up

Re: GoToWebinar Connection continually disconnecting

Hi there,

 

I have exactly the same problem, but I think the reason is the refresh Token. After a while, the connection is lost and the log of the flow shows the following error messagre: {"int_err_code":"InvalidToken","msg":"Invalid token passed"}

 

After a manually re-login under the connections, the flow works fine. Any idea how to add a refresh token to the flow?

 

Thank you.

Highlighted
v-zhos-msft
Level 10

Re: GoToWebinar Connection continually disconnecting

Hi @Rockman ,

I am afraid that there is no way to achieve your needs in Microsoft Flow currently.

There is no actions about refreshing the flow.

If you would like this feature to be added in Microsoft Flow, please submit an idea to Flow Ideas Forum:

https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons in April

Read the announcement for more information!

firstImage

Better Together Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Kudoed Authors
Users online (5,118)