cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lguest
Level: Power Up

GoToWebinar Connection continually disconnecting

We are using the GoToWebinar connector within Flow to manage our webinar registrants. The flow is triggered when a posted form from our website is submitted which creates a record in Dynamics CRM (this is the trigger that starts the flow), from there we determine if the posted form was an upcoming webinar form and from this we do a get lead/contact record. The record is then added to GoToWebinar as a registrant and sent an Outlook meeting invite with their specific registrant join URL which is created by GoToWebinar. 

When the connection is active, this Flow works great, however if the Flow is inactive for longer than a 15 - 20 min time window, the connection fails and the next user that registers does not receive any GoToWebinar details as the Flow failed. 

I even tried setting up a template with the GoToWebinar directly from Microsoft and was still having issues with the connection. We have not changed any credentials to our GoToWebinar account.

Is anyone else having issues keeping their GoToWebinar connection active? 

3 REPLIES 3
v-zhos-msft
Level 10

Re: GoToWebinar Connection continually disconnecting

Hi @lguest ,

Could you please share a screenshot of failure Run history with the error message?

I am confused about that why the connection will be inactive.

You can check the connection status in the flow:

If the status is connected, it means there is no problem of the connection.

InkedCapture3_LI.jpg

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Rockman
Level: Power Up

Re: GoToWebinar Connection continually disconnecting

Hi there,

 

I have exactly the same problem, but I think the reason is the refresh Token. After a while, the connection is lost and the log of the flow shows the following error messagre: {"int_err_code":"InvalidToken","msg":"Invalid token passed"}

 

After a manually re-login under the connections, the flow works fine. Any idea how to add a refresh token to the flow?

 

Thank you.

v-zhos-msft
Level 10

Re: GoToWebinar Connection continually disconnecting

Hi @Rockman ,

I am afraid that there is no way to achieve your needs in Microsoft Flow currently.

There is no actions about refreshing the flow.

If you would like this feature to be added in Microsoft Flow, please submit an idea to Flow Ideas Forum:

https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Users Online
Currently online: 445 members 5,877 guests
Please welcome our newest community members: